[arm] Fix the world famous typo with is_gate_vma()

svn path=/dists/sid/linux/; revision=20498
This commit is contained in:
Ben Hutchings 2013-08-15 19:10:12 +00:00
parent d8699be530
commit d93c147e57
3 changed files with 25 additions and 0 deletions

1
debian/changelog vendored
View File

@ -68,6 +68,7 @@ linux (3.10.7-1) UNRELEASED; urgency=low
* [x86] Enable ASUS_OLED as module (Closes: #680016)
* [armel/orion5x] I2C: mv64xxx: fix race between FSM/interrupt and process
context (Closes: #622325)
* [arm] Fix the world famous typo with is_gate_vma()
[ Thorsten Glaser ]
* [m68k] debian/patches/bugfix/m68k/atari-irqs.patch: patch from mailing list

View File

@ -0,0 +1,23 @@
From: Russell King <rmk+kernel@arm.linux.org.uk>
Date: Tue, 6 Aug 2013 09:49:14 +0100
Subject: ARM: Fix the world famous typo with is_gate_vma()
Origin: http://ftp.arm.linux.org.uk/pub/linux/arm/kernel/git-cur/linux-arm.git/ commit 1d0bbf428924f94867542d49d436cf254b9dbd06
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
---
arch/arm/kernel/process.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/kernel/process.c b/arch/arm/kernel/process.c
index d03b5bd..e28d43f 100644
--- a/arch/arm/kernel/process.c
+++ b/arch/arm/kernel/process.c
@@ -459,7 +459,7 @@ int in_gate_area_no_mm(unsigned long addr)
{
return in_gate_area(NULL, addr);
}
-#define is_gate_vma(vma) ((vma) = &gate_vma)
+#define is_gate_vma(vma) ((vma) == &gate_vma)
#else
#define is_gate_vma(vma) 0
#endif

View File

@ -120,3 +120,4 @@ bugfix/m68k/type-fix-div64.patch
bugfix/arm/I2C-I2C-mv64xxx-remove-I2C_M_NOSTART-code.patch
bugfix/arm/I2C-mv64xxx-move-mv64xxx_i2c_prepare_for_io.patch
bugfix/arm/I2C-mv64xxx-fix-race-between-FSM-interrupt-and-proce.patch
bugfix/arm/ARM-Fix-the-world-famous-typo-with-is_gate_vma.patch