Merge changes from sid up to 3.9.5-1

svn path=/dists/trunk/linux/; revision=20231
This commit is contained in:
Ben Hutchings 2013-06-10 04:27:15 +00:00
commit da3c6d6427
17 changed files with 260 additions and 32 deletions

66
debian/changelog vendored
View File

@ -22,6 +22,72 @@ linux (3.10~rc4-1~exp1) experimental; urgency=low
-- Ben Hutchings <ben@decadent.org.uk> Mon, 03 Jun 2013 02:43:51 +0100
linux (3.9.5-1) unstable; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.9.5
- [arm] 7723/1: crypto: sha1-armv4-large.S: fix SP handling
- mac80211: use just spin_lock() in ieee80211_get_tkip_p2k()
- USB: cxacru: potential underflow in cxacru_cm_get_array()
- TTY: Fix tty miss restart after we turn off flow-control
(Closes: #465823)
- cifs: only set ops for inodes in I_NEW state
- drivers/char/random.c: fix priming of last_data
- random: fix accounting race condition with lockless irq entropy_count
update
- fat: fix possible overflow for fat_clusters
- tg3: Fix data corruption on 5725 with TSO
- ocfs2: goto out_unlock if ocfs2_get_clusters_nocache() failed in
ocfs2_fiemap()
- mm compaction: fix of improper cache flush in migration code
- klist: del waiter from klist_remove_waiters before wakeup waitting process
- wait: fix false timeouts when using wait_event_timeout()
- nilfs2: fix issue of nilfs_set_page_dirty() for page at EOF boundary
- mm: mmu_notifier: re-fix freed page still mapped in secondary MMU
- mm: memcg: remove incorrect VM_BUG_ON for swap cache pages in uncharge
- mm/pagewalk.c: walk_page_range should avoid VM_PFNMAP areas
- mm/THP: use pmd_populate() to update the pmd with pgtable_t pointer
- module: don't unlink the module until we've removed all exposure.
- xfs: kill suid/sgid through the truncate path.
- SUNRPC: Prevent an rpc_task wakeup race
- cifs: fix potential buffer overrun when composing a new options string
- cgroup: initialize xattr before calling d_instantiate()
- [powerpc] 32bit:Store temporary result in r0 instead of r8
- [powerpc] tm: Fix userspace stack corruption on signal delivery for active
transactions
- [powerpc] tm: Abort on emulation and alignment faults
- iscsi-target: fix heap buffer overflow on error
- KVM: fix sil/dil/bpl/spl in the mod/rm fields
- reiserfs: fix deadlock with nfs racing on create/lookup
- reiserfs: fix problems with chowning setuid file w/ xattrs
- reiserfs: fix spurious multiple-fill in reiserfs_readdir_dentry
- jfs: fix a couple races
- IB/iser: Return error to upper layers on EAGAIN registration failures
- fuse: fix readdirplus Oops in fuse_dentry_revalidate
- target: Re-instate sess_wait_list for target_wait_for_sess_cmds
- xen-netback: Fix regressions caused by fix for CVE-2013-0216
+ coalesce slots in TX path and fix regressions
+ don't disconnect frontend when seeing oversize packet
[ Ben Hutchings ]
* [powerpcspe] Remove installer udebs (really fixes FTBFS)
* [s390] Add pgste to ptep_modify_prot_start()
* [s390] Enable PCI, PCI and USB drivers
* [powerpc] Fix build error in stable/3.9
* [armel/iop32x,armel/ixp4xx] Disable OABI_COMPAT, PCI_QUIRKS to reduce
kernel size (fixes FTBFS)
* ath9k: Disable PowerSave by default (Closes: #695968)
* [i386] udeb: Add viafb to fb-modules (Closes: #705788)
- [i386] udeb: Move i2c-algo-bit to i2c-modules and make fb-modules
depend on it
- viafb: Autoload on OLPC XO 1.5 only
* fs: Enable F2FS_FS as module (Closes: #711342)
* iio,HID: Enable IIO, HID_SENSOR_HUB, HID_SENSOR_ACCEL_3D,
HID_SENSOR_ALS, HID_SENSOR_GYRO_3D, HID_SENSOR_MAGNETOMETER_3D
as modules (Closes: #711690)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 10 Jun 2013 02:41:53 +0100
linux (3.9.4-1) unstable; urgency=low
* New upstream release: http://kernelnewbies.org/Linux_3.9

View File

@ -22,15 +22,14 @@ CONFIG_ARCH_IOP32X=y
# CONFIG_ARCH_OMAP is not set
## end choice
CONFIG_PCI=y
#. This also disables FP emulation, which saves over 20K
# CONFIG_OABI_COMPAT is not set
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
CONFIG_CMDLINE=""
# CONFIG_XIP_KERNEL is not set
CONFIG_KEXEC=y
CONFIG_ATAGS_PROC=y
CONFIG_FPE_NWFPE=y
# CONFIG_FPE_NWFPE_XP is not set
# CONFIG_FPE_FASTFPE is not set
# CONFIG_ARTHUR is not set
##
@ -482,6 +481,12 @@ CONFIG_TMD_HERMES=m
CONFIG_NORTEL_HERMES=m
CONFIG_PCI_HERMES=m
##
## file: drivers/pci/Kconfig
##
#. Saves about 17K, and none of the quirks are likely to be needed
# CONFIG_PCI_QUIRKS is not set
##
## file: drivers/pcmcia/Kconfig
##
@ -586,6 +591,7 @@ CONFIG_BINFMT_AOUT=m
##
## file: init/Kconfig
##
# CONFIG_AUDITSYSCALL is not set
CONFIG_LOG_BUF_SHIFT=14
CONFIG_NAMESPACES=y
CONFIG_UTS_NS=y

View File

@ -22,15 +22,14 @@ CONFIG_ARCH_IXP4XX=y
# CONFIG_ARCH_OMAP is not set
## end choice
CONFIG_PCI=y
#. This also disables FP emulation, which saves over 20K
# CONFIG_OABI_COMPAT is not set
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
CONFIG_CMDLINE="console=ttyS0,115200"
# CONFIG_XIP_KERNEL is not set
CONFIG_KEXEC=y
CONFIG_ATAGS_PROC=y
CONFIG_FPE_NWFPE=y
# CONFIG_FPE_NWFPE_XP is not set
# CONFIG_FPE_FASTFPE is not set
# CONFIG_ARTHUR is not set
##
@ -560,6 +559,12 @@ CONFIG_TMD_HERMES=m
CONFIG_NORTEL_HERMES=m
CONFIG_PCI_HERMES=m
##
## file: drivers/pci/Kconfig
##
#. Saves about 17K, and none of the quirks are likely to be needed
# CONFIG_PCI_QUIRKS is not set
##
## file: drivers/pcmcia/Kconfig
##
@ -720,6 +725,7 @@ CONFIG_BINFMT_AOUT=m
##
## file: init/Kconfig
##
# CONFIG_AUDITSYSCALL is not set
CONFIG_LOG_BUF_SHIFT=14
CONFIG_NAMESPACES=y
CONFIG_UTS_NS=y

100
debian/config/config vendored
View File

@ -490,6 +490,7 @@ CONFIG_HID_WIIMOTE_EXT=y
CONFIG_HID_ZEROPLUS=m
CONFIG_ZEROPLUS_FF=y
CONFIG_HID_ZYDACRON=m
CONFIG_HID_SENSOR_HUB=m
##
## file: drivers/hid/usbhid/Kconfig
@ -632,7 +633,96 @@ CONFIG_I7300_IDLE=m
##
## file: drivers/iio/Kconfig
##
# CONFIG_IIO is not set
CONFIG_IIO=m
CONFIG_IIO_BUFFER=y
#. These will be selected by drivers that need them
# CONFIG_IIO_BUFFER_CB is not set
# CONFIG_IIO_KFIFO_BUF is not set
# CONFIG_IIO_TRIGGERED_BUFFER is not set
# CONFIG_IIO_TRIGGER is not set
##
## file: drivers/iio/accel/Kconfig
##
CONFIG_HID_SENSOR_ACCEL_3D=m
# CONFIG_KXSD9 is not set
# CONFIG_IIO_ST_ACCEL_3AXIS is not set
##
## file: drivers/iio/adc/Kconfig
##
# CONFIG_AD7266 is not set
# CONFIG_AD7298 is not set
# CONFIG_AD7791 is not set
# CONFIG_AD7793 is not set
# CONFIG_AD7476 is not set
# CONFIG_AD7887 is not set
# CONFIG_MAX1363 is not set
# CONFIG_TI_ADC081C is not set
##
## file: drivers/iio/amplifiers/Kconfig
##
# CONFIG_AD8366 is not set
##
## file: drivers/iio/dac/Kconfig
##
# CONFIG_AD5064 is not set
# CONFIG_AD5360 is not set
# CONFIG_AD5380 is not set
# CONFIG_AD5421 is not set
# CONFIG_AD5624R_SPI is not set
# CONFIG_AD5446 is not set
# CONFIG_AD5449 is not set
# CONFIG_AD5504 is not set
# CONFIG_AD5755 is not set
# CONFIG_AD5764 is not set
# CONFIG_AD5791 is not set
# CONFIG_AD5686 is not set
# CONFIG_MAX517 is not set
# CONFIG_MCP4725 is not set
##
## file: drivers/iio/frequency/Kconfig
##
# CONFIG_AD9523 is not set
# CONFIG_ADF4350 is not set
##
## file: drivers/iio/gyro/Kconfig
##
# CONFIG_ADIS16080 is not set
# CONFIG_ADIS16136 is not set
# CONFIG_ADXRS450 is not set
CONFIG_HID_SENSOR_GYRO_3D=m
# CONFIG_IIO_ST_GYRO_3AXIS is not set
# CONFIG_ITG3200 is not set
##
## file: drivers/iio/imu/Kconfig
##
# CONFIG_ADIS16400 is not set
# CONFIG_ADIS16480 is not set
##
## file: drivers/iio/imu/inv_mpu6050/Kconfig
##
# CONFIG_INV_MPU6050_IIO is not set
##
## file: drivers/iio/light/Kconfig
##
# CONFIG_ADJD_S311 is not set
# CONFIG_SENSORS_TSL2563 is not set
# CONFIG_VCNL4000 is not set
CONFIG_HID_SENSOR_ALS=m
##
## file: drivers/iio/magnetometer/Kconfig
##
CONFIG_HID_SENSOR_MAGNETOMETER_3D=m
# CONFIG_IIO_ST_MAGN_3AXIS is not set
##
## file: drivers/infiniband/Kconfig
@ -3704,6 +3794,14 @@ CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
# CONFIG_EXT4_DEBUG is not set
##
## file: fs/f2fs/Kconfig
##
CONFIG_F2FS_FS=m
CONFIG_F2FS_STAT_FS=y
CONFIG_F2FS_FS_XATTR=y
CONFIG_F2FS_FS_POSIX_ACL=y
##
## file: fs/fat/Kconfig
##

View File

@ -1,5 +1,8 @@
[abi]
abiname: trunk
ignore-changes:
module:drivers/scsi/qla2xxx/qla2xxx
module:drivers/target/*
[base]
arches:

View File

@ -9,4 +9,5 @@ CONFIG_MARCH_Z900=y
# CONFIG_MARCH_Z10 is not set
## end choice
CONFIG_64BIT=y
CONFIG_PCI=y

View File

@ -2,3 +2,4 @@ fbcon ?
lxfb ?
vesafb ?
vga16fb
viafb

View File

@ -1 +1,2 @@
#include <i2c-modules>
i2c-algo-bit

View File

@ -21,3 +21,6 @@ Depends: kernel-image, core-modules
Package: nbd-modules
Depends: kernel-image
Package: fb-modules
Depends: kernel-image, i2c-modules

View File

@ -1,2 +0,0 @@
# arch version flavour installedname suffix build-depends
powerpcspe - powerpcspe - - -

View File

@ -1 +0,0 @@
../../powerpc/modules/powerpc

View File

@ -1 +0,0 @@
../../powerpc/modules/powerpc

View File

@ -1 +0,0 @@
../../powerpc/modules/powerpc-powerpc-miboot/

View File

@ -1,20 +0,0 @@
# This file is used to build up the control file. The kernel version and
# "-di" are appended to the package names. Section can be left out. So can
# architecture, which is derived from the files in the modules directory.
# It overwrites specifications from /usr/share/kernel-wedge/package-list.
#
Package: pata-modules
Depends: kernel-image, ata-modules, core-modules
Package: scsi-modules
Depends: kernel-image, scsi-core-modules, parport-modules, cdrom-core-modules, core-modules, ata-modules
Package: pcmcia-modules
Depends: kernel-image, core-modules
Package: nic-pcmcia-modules
Depends: kernel-image, nic-modules, nic-shared-modules, nic-wireless-modules, pcmcia-modules, core-modules
Package: nbd-modules
Depends: kernel-image

View File

@ -0,0 +1,32 @@
From: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date: Sat, 1 Jun 2013 07:08:09 +0530
Subject: ath9k: Disable PowerSave by default
commit 73c79617596b89a3693ff0d89d42bcd5ddedcf15 upstream.
Almost all the DMA issues which have plagued ath9k (in station mode)
for years are related to PS. Disabling PS usually "fixes" the user's
connection stablility. Reports of DMA problems are still trickling in
and are sitting in the kernel bugzilla. Until the PS code in ath9k is
given a thorough review, disbale it by default. The slight increase
in chip power consumption is a small price to pay for improved link
stability.
Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/ath/ath9k/init.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -766,8 +766,7 @@ void ath9k_set_hw_capab(struct ath_softc
hw->wiphy->iface_combinations = &if_comb;
hw->wiphy->n_iface_combinations = 1;
- if (AR_SREV_5416(sc->sc_ah))
- hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
+ hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
hw->wiphy->flags |= WIPHY_FLAG_IBSS_RSN;
hw->wiphy->flags |= WIPHY_FLAG_SUPPORTS_TDLS;

View File

@ -0,0 +1,33 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 20 Apr 2013 15:52:02 +0100
Subject: viafb: Autoload on OLPC XO 1.5 only
Bug-Debian: http://bugs.debian.org/705788
It appears that viafb won't work automatically on all the boards for
which it has a PCI device ID match. Currently, it is blacklisted by
udev along with most other framebuffer drivers, so this doesn't matter
much.
However, this driver is required for console support on the XO 1.5.
We need to allow it to be autoloaded on this model only, and then
un-blacklist it in udev.
---
--- a/drivers/video/via/via-core.c
+++ b/drivers/video/via/via-core.c
@@ -753,7 +753,14 @@ static struct pci_device_id via_pci_tabl
.driver_data = UNICHROME_VX900 },
{ }
};
-MODULE_DEVICE_TABLE(pci, via_pci_table);
+
+static const struct pci_device_id via_pci_autoload_table[] __initconst = {
+ /* OLPC XO 1.5 */
+ { PCI_DEVICE(PCI_VENDOR_ID_VIA, UNICHROME_VX855_DID),
+ .subvendor = 0x152d, .subdevice = 0x0833 },
+ { }
+};
+MODULE_DEVICE_TABLE(pci, via_pci_autoload_table);
static struct pci_driver via_driver = {
.name = "viafb",

View File

@ -84,3 +84,6 @@ features/arm/ARM-dts-imx-use-usb-nop-xceiv-usbphy-entries-for-imx5x.patch
features/arm/ARM-dts-imx-imx53-qsb.dts-enable-usbotg-and-usbh1.patch
features/arm/usbmisc-imx-add-module_device_table.patch
features/arm/imx53-qsb-usb-power.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch