aufs: Update support patchest to aufs4.9-20161219

This commit is contained in:
Ben Hutchings 2017-01-05 04:20:11 +00:00
parent ec36e35f50
commit dacad5c64e
4 changed files with 163 additions and 79 deletions

1
debian/changelog vendored
View File

@ -16,6 +16,7 @@ linux (4.9-1~exp1) UNRELEASED; urgency=medium
previous, Closes: #847017)
* net: Enable GTP as module (Closes: #846913)
* [armhf] gpio: Enable GPIO_MCP23S08 as module (Closes: #845064)
* aufs: Update support patchest to aufs4.9-20161219
[ Uwe Kleine-König ]
* enable `perf data' support; patch by Sebastian Andrzej Siewior

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Date: Fri Dec 16 21:28:57 2016 +0900
Subject: aufs4.9 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.8 base patch
[bwh: Forward-ported to 4.9: adjust context]
aufs4.9 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 63cefa6..d78b954 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2285,6 +2285,19 @@ F: include/linux/audit.h
@@ -2293,6 +2293,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -32,9 +32,11 @@ aufs4.8 base patch
AUXILIARY DISPLAY DRIVERS
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index fa1b7a9..6ee9235 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -701,6 +701,24 @@ static inline int is_loop_device(struct
@@ -701,6 +701,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
}
@ -59,6 +61,8 @@ aufs4.8 base patch
/* loop sysfs attributes */
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index 5c7cc95..df0268c 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1164,7 +1164,7 @@ enum d_walk_ret {
@ -70,6 +74,8 @@ aufs4.8 base patch
enum d_walk_ret (*enter)(void *, struct dentry *),
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 350a2c8..6f42279 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -29,7 +29,7 @@
@ -81,7 +87,7 @@ aufs4.8 base patch
{
struct inode * inode = file_inode(filp);
int error = 0;
@@ -60,6 +60,8 @@ static int setfl(int fd, struct file * f
@@ -60,6 +60,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
if (filp->f_op->check_flags)
error = filp->f_op->check_flags(arg);
@ -90,9 +96,11 @@ aufs4.8 base patch
if (error)
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 88110fd..9a9ba3a 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1642,7 +1642,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1642,7 +1642,7 @@ int generic_update_time(struct inode *inode, struct timespec *time, int flags)
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -101,9 +109,11 @@ aufs4.8 base patch
{
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index 190e0d36..4052813 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -515,6 +515,28 @@ ssize_t __vfs_write(struct file *file, c
@@ -515,6 +515,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
}
EXPORT_SYMBOL(__vfs_write);
@ -132,9 +142,11 @@ aufs4.8 base patch
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index 5a7750b..28160a7 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -859,8 +859,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@@ -855,8 +855,8 @@ ssize_t generic_splice_sendpage(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -145,7 +157,7 @@ aufs4.8 base patch
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -876,9 +876,9 @@ static long do_splice_from(struct pipe_i
@@ -872,9 +872,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -158,9 +170,11 @@ aufs4.8 base patch
{
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/file.h b/include/linux/file.h
index 7444f5f..bdac0be 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -19,6 +19,7 @@ struct dentry;
@@ -19,6 +19,7 @@
struct path;
extern struct file *alloc_file(struct path *, fmode_t mode,
const struct file_operations *fop);
@ -168,9 +182,11 @@ aufs4.8 base patch
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index dc0478c..27c05e7 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1290,6 +1290,7 @@ extern void fasync_free(struct fasync_st
@@ -1291,6 +1291,7 @@ struct fasync_struct {
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -186,7 +202,7 @@ aufs4.8 base patch
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1768,6 +1770,12 @@ ssize_t rw_copy_check_uvector(int type,
@@ -1768,6 +1770,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -199,7 +215,7 @@ aufs4.8 base patch
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t __vfs_write(struct file *, const char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
@@ -2140,6 +2148,7 @@ extern int current_umask(void);
@@ -2140,6 +2148,7 @@ extern int iterate_mounts(int (*)(struct vfsmount *, void *), void *,
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -207,9 +223,11 @@ aufs4.8 base patch
/* /sys/fs */
extern struct kobject *fs_kobj;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 00a2116..1f0a4a2 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -86,4 +86,10 @@ extern void spd_release_page(struct spli
@@ -86,4 +86,10 @@ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;
extern const struct pipe_buf_operations default_pipe_buf_ops;

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Date: Fri Dec 16 21:28:57 2016 +0900
Subject: aufs4.9 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.8 mmap patch
[bwh: Forward-ported to 4.9: adjust context]
aufs4.9 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index ca651ac..0e8551a 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1952,7 +1952,7 @@ static int map_files_get_link(struct den
@@ -1953,7 +1953,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -21,9 +21,11 @@ aufs4.8 mmap patch
path_get(path);
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index f8595e8..cb8eda0 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
file = region->vm_file;
if (file) {
@ -35,9 +37,11 @@ aufs4.8 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 35b92d8..5b981db 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -291,7 +291,10 @@ show_map_vma(struct seq_file *m, struct
@@ -291,7 +291,10 @@ static int is_stack(struct proc_maps_private *priv,
const char *name = NULL;
if (file) {
@ -49,7 +53,7 @@ aufs4.8 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1627,7 +1630,7 @@ static int show_numa_map(struct seq_file
@@ -1627,7 +1630,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -58,9 +62,11 @@ aufs4.8 mmap patch
struct mm_struct *mm = vma->vm_mm;
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 3717562..6a328f1 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_fil
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -72,9 +78,11 @@ aufs4.8 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index a92c8d7..1d83a2a 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1266,6 +1266,28 @@ static inline int fixup_user_fault(struc
@@ -1266,6 +1266,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -103,6 +111,8 @@ aufs4.8 mmap patch
extern int access_process_vm(struct task_struct *tsk, unsigned long addr, void *buf, int len,
unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 4a8aced..badd16b 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -275,6 +275,7 @@ struct vm_region {
@ -121,9 +131,11 @@ aufs4.8 mmap patch
void * vm_private_data; /* was vm_pte (shared mem) */
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 997ac1d..4d0131b 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -621,7 +621,7 @@ static __latent_entropy int dup_mmap(str
@@ -624,7 +624,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -132,9 +144,11 @@ aufs4.8 mmap patch
if (tmp->vm_flags & VM_DENYWRITE)
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 295bd7a..14fa1c8 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -37,7 +37,7 @@ obj-y := filemap.o mempool.o oom_kill.
@@ -37,7 +37,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o \
interval_tree.o list_lru.o workingset.o \
@ -143,9 +157,11 @@ aufs4.8 mmap patch
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 50b52fe..9e607f9 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2303,7 +2303,7 @@ int filemap_page_mkwrite(struct vm_area_
@@ -2304,7 +2304,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -154,9 +170,11 @@ aufs4.8 mmap patch
lock_page(page);
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/memory.c b/mm/memory.c
index e18c57b..7be4a39 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -2117,7 +2117,7 @@ static inline int wp_page_reuse(struct f
@@ -2117,7 +2117,7 @@ static inline int wp_page_reuse(struct fault_env *fe, pte_t orig_pte,
}
if (!page_mkwrite)
@ -165,9 +183,11 @@ aufs4.8 mmap patch
}
return VM_FAULT_WRITE;
diff --git a/mm/mmap.c b/mm/mmap.c
index 1af87c1..95b0ff4 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -170,7 +170,7 @@ static struct vm_area_struct *remove_vma
@@ -170,7 +170,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -176,7 +196,7 @@ aufs4.8 mmap patch
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -879,7 +879,7 @@ again:
@@ -879,7 +879,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -185,7 +205,7 @@ aufs4.8 mmap patch
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1727,8 +1727,8 @@ out:
@@ -1727,8 +1727,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -195,7 +215,7 @@ aufs4.8 mmap patch
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2533,7 +2533,7 @@ static int __split_vma(struct mm_struct
@@ -2533,7 +2533,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -204,7 +224,7 @@ aufs4.8 mmap patch
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2552,7 +2552,7 @@ static int __split_vma(struct mm_struct
@@ -2552,7 +2552,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -213,7 +233,7 @@ aufs4.8 mmap patch
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2703,7 +2703,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2703,7 +2703,7 @@ int vm_munmap(unsigned long start, size_t len)
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -222,7 +242,7 @@ aufs4.8 mmap patch
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2778,10 +2778,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2778,10 +2778,27 @@ int vm_munmap(unsigned long start, size_t len)
}
}
@ -251,7 +271,7 @@ aufs4.8 mmap patch
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3056,7 +3073,7 @@ struct vm_area_struct *copy_vma(struct v
@@ -3056,7 +3073,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -260,9 +280,11 @@ aufs4.8 mmap patch
if (new_vma->vm_ops && new_vma->vm_ops->open)
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 8b8faaf..5d26ed94 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -636,7 +636,7 @@ static void __put_nommu_region(struct vm
@@ -636,7 +636,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -271,7 +293,7 @@ aufs4.8 mmap patch
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -794,7 +794,7 @@ static void delete_vma(struct mm_struct
@@ -794,7 +794,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -289,7 +311,7 @@ aufs4.8 mmap patch
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1395,10 +1395,10 @@ error_just_free:
@@ -1395,10 +1395,10 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)
@ -302,6 +324,9 @@ aufs4.8 mmap patch
kmem_cache_free(vm_area_cachep, vma);
return ret;
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..b323b8a
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@

View File

@ -1,16 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Date: Fri Dec 16 21:28:57 2016 +0900
Subject: aufs4.9 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.8 standalone patch
aufs4.9 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index df0268c..755fea1 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1272,6 +1272,7 @@ rename_retry:
@@ -1272,6 +1272,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -18,9 +20,19 @@ aufs4.8 standalone patch
/*
* Search for at least 1 mount point in the dentry's subdirs.
@@ -2855,6 +2856,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
+EXPORT_SYMBOL_GPL(d_exchange);
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 4e497b9..e27d323 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path)
return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
}
@ -28,9 +40,11 @@ aufs4.8 standalone patch
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 6f42279..04fd33c 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -82,6 +82,7 @@ int setfl(int fd, struct file * filp, un
@@ -82,6 +82,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -38,9 +52,11 @@ aufs4.8 standalone patch
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index ad17e05..ae9f267 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -147,6 +147,7 @@ over:
@@ -147,6 +147,7 @@ struct file *get_empty_filp(void)
}
return ERR_PTR(-ENFILE);
}
@ -72,9 +88,11 @@ aufs4.8 standalone patch
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index 9a9ba3a..a3a18d8 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1651,6 +1651,7 @@ int update_time(struct inode *inode, str
@@ -1651,6 +1651,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
@ -82,9 +100,11 @@ aufs4.8 standalone patch
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index e6c234b..8d13f7b 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -466,6 +466,7 @@ void __mnt_drop_write(struct vfsmount *m
@@ -466,6 +466,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -92,7 +112,7 @@ aufs4.8 standalone patch
/**
* mnt_drop_write - give up write access to a mount
@@ -1823,6 +1824,7 @@ int iterate_mounts(int (*f)(struct vfsmo
@@ -1823,6 +1824,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -100,6 +120,8 @@ aufs4.8 standalone patch
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index fbe3cbe..bdfc61e 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -110,7 +132,7 @@ aufs4.8 standalone patch
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -100,6 +101,7 @@ void fsnotify_get_group(struct fsnotify_
@@ -100,6 +101,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
atomic_inc(&group->refcnt);
}
@ -118,7 +140,7 @@ aufs4.8 standalone patch
/*
* Drop a reference to a group. Free it if it's through.
@@ -109,6 +111,7 @@ void fsnotify_put_group(struct fsnotify_
@@ -109,6 +111,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (atomic_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -126,7 +148,7 @@ aufs4.8 standalone patch
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -137,6 +140,7 @@ struct fsnotify_group *fsnotify_alloc_gr
@@ -137,6 +140,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -134,9 +156,11 @@ aufs4.8 standalone patch
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index d3fea0b..5fc06ad 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_m
@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
mark->free_mark(mark);
}
}
@ -144,7 +168,7 @@ aufs4.8 standalone patch
/* Calculate mask of events for a list of marks */
u32 fsnotify_recalc_mask(struct hlist_head *head)
@@ -230,6 +231,7 @@ void fsnotify_destroy_mark(struct fsnoti
@@ -230,6 +231,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -152,7 +176,7 @@ aufs4.8 standalone patch
void fsnotify_destroy_marks(struct hlist_head *head, spinlock_t *lock)
{
@@ -415,6 +417,7 @@ err:
@@ -415,6 +417,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark,
return ret;
}
@ -160,7 +184,7 @@ aufs4.8 standalone patch
int fsnotify_add_mark(struct fsnotify_mark *mark, struct fsnotify_group *group,
struct inode *inode, struct vfsmount *mnt, int allow_dups)
@@ -533,6 +536,7 @@ void fsnotify_init_mark(struct fsnotify_
@@ -533,6 +536,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
atomic_set(&mark->refcnt, 1);
mark->free_mark = free_mark;
}
@ -168,9 +192,11 @@ aufs4.8 standalone patch
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index d3ed817..20d2494 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, l
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
inode_unlock(dentry->d_inode);
return ret;
}
@ -186,6 +212,8 @@ aufs4.8 standalone patch
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index 4052813..7dfd732 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -525,6 +525,7 @@ vfs_readf_t vfs_readf(struct file *file)
@ -196,7 +224,7 @@ aufs4.8 standalone patch
vfs_writef_t vfs_writef(struct file *file)
{
@@ -536,6 +537,7 @@ vfs_writef_t vfs_writef(struct file *fil
@@ -536,6 +537,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -204,9 +232,11 @@ aufs4.8 standalone patch
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
diff --git a/fs/splice.c b/fs/splice.c
index 28160a7..98c1902 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -872,6 +872,7 @@ long do_splice_from(struct pipe_inode_in
@@ -868,6 +868,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -214,7 +244,7 @@ aufs4.8 standalone patch
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -901,6 +902,7 @@ long do_splice_to(struct file *in, loff_
@@ -897,6 +898,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -222,9 +252,11 @@ aufs4.8 standalone patch
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/xattr.c b/fs/xattr.c
index 2d13b4e..41c2bcd 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -290,6 +290,7 @@ vfs_getxattr_alloc(struct dentry *dentry
@@ -296,6 +296,7 @@ int __vfs_setxattr_noperm(struct dentry *dentry, const char *name,
*xattr_value = value;
return error;
}
@ -232,6 +264,8 @@ aufs4.8 standalone patch
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/task_work.c b/kernel/task_work.c
index d513051..e056d54 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -119,3 +119,4 @@ void task_work_run(void)
@ -239,6 +273,8 @@ aufs4.8 standalone patch
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 8df676f..6b5cc07 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1061,12 +1061,14 @@ int cap_mmap_addr(unsigned long addr)
@ -256,6 +292,8 @@ aufs4.8 standalone patch
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 03c1652..f88c84b 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@ -266,7 +304,7 @@ aufs4.8 standalone patch
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask)
return __devcgroup_check_permission(type, imajor(inode), iminor(inode),
access);
}
@ -274,9 +312,11 @@ aufs4.8 standalone patch
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index f825304..8dd441d 100644
--- a/security/security.c
+++ b/security/security.c
@@ -443,6 +443,7 @@ int security_path_rmdir(const struct pat
@@ -443,6 +443,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -284,7 +324,7 @@ aufs4.8 standalone patch
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -459,6 +460,7 @@ int security_path_symlink(const struct p
@@ -459,6 +460,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -292,7 +332,7 @@ aufs4.8 standalone patch
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -467,6 +469,7 @@ int security_path_link(struct dentry *ol
@@ -467,6 +469,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -300,7 +340,7 @@ aufs4.8 standalone patch
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -494,6 +497,7 @@ int security_path_truncate(const struct
@@ -494,6 +497,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -308,7 +348,7 @@ aufs4.8 standalone patch
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -501,6 +505,7 @@ int security_path_chmod(const struct pat
@@ -501,6 +505,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -316,7 +356,7 @@ aufs4.8 standalone patch
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -508,6 +513,7 @@ int security_path_chown(const struct pat
@@ -508,6 +513,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -324,7 +364,7 @@ aufs4.8 standalone patch
int security_path_chroot(const struct path *path)
{
@@ -593,6 +599,7 @@ int security_inode_readlink(struct dentr
@@ -593,6 +599,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -332,7 +372,7 @@ aufs4.8 standalone patch
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -608,6 +615,7 @@ int security_inode_permission(struct ino
@@ -608,6 +615,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -340,7 +380,7 @@ aufs4.8 standalone patch
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -779,6 +787,7 @@ int security_file_permission(struct file
@@ -779,6 +787,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -348,7 +388,7 @@ aufs4.8 standalone patch
int security_file_alloc(struct file *file)
{
@@ -838,6 +847,7 @@ int security_mmap_file(struct file *file
@@ -838,6 +847,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}