Update IXP4xx Ethernet patches.

svn path=/dists/trunk/linux-2.6/; revision=10275
This commit is contained in:
Martin Michlmayr 2008-01-30 04:18:17 +00:00
parent c72dff495a
commit e2e687b75a
5 changed files with 96 additions and 55 deletions

4
debian/changelog vendored
View File

@ -1,7 +1,11 @@
linux-2.6 (2.6.24-trunk1) UNRELEASED; urgency=low
[ maximilian attems ]
* Fake version
[ Martin Michlmayr ]
* [arm] Update IXP4xx Ethernet patches.
-- maximilian attems <maks@debian.org> Tue, 29 Jan 2008 22:14:41 +0100
linux-2.6 (2.6.24-1~experimental.1) UNRELEASED; urgency=low

View File

@ -1,20 +1,21 @@
diff --git a/include/asm-arm/arch-ixp4xx/platform.h b/include/asm-arm/arch-ixp4xx/platform.h
index 2a44d3d..695b9c4 100644
http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=4714/2
From: Krzysztof Halasa
Adds platform structs and #defines required by drivers for
IXP4xx built-in Ethernet and WAN (sync serial) ports.
The actual drivers will reside in drivers/net/arm and
drivers/net/wan and will be submitted separately.
Signed-off-by: Krzysztof Halasa
Signed-off-by: Rod Whitby
--- a/include/asm-arm/arch-ixp4xx/platform.h
+++ b/include/asm-arm/arch-ixp4xx/platform.h
@@ -77,8 +77,7 @@ extern unsigned long ixp4xx_exp_bus_size;
@@ -91,6 +91,27 @@ struct ixp4xx_pata_data {
/*
* The IXP4xx chips do not have an I2C unit, so GPIO lines are just
- * used to
- * Used as platform_data to provide GPIO pin information to the ixp42x
+ * used as platform_data to provide GPIO pin information to the ixp42x
* I2C driver.
*/
struct ixp4xx_i2c_pins {
@@ -86,6 +85,27 @@ struct ixp4xx_i2c_pins {
unsigned long scl_pin;
};
struct sys_timer;
+#define IXP4XX_ETH_NPEA 0x00
+#define IXP4XX_ETH_NPEB 0x10
@ -38,7 +39,6 @@ index 2a44d3d..695b9c4 100644
+};
+
/*
* This structure provide a means for the board setup code
* to give information to th pata_ixp4xx driver. It is
* Frequency of clock used for primary clocksource
*/

View File

@ -1,8 +1,27 @@
Enables the new ixp4xx qmgr and npe drivers in ixp4xx_defconfig.
Sets up the corresponding platform data for the nslu2 and nas100d
boards, and reads the ethernet MAC address from the internal flash.
Tested on both little-endian and big-endian kernels.
Signed-off-by: Rod Whitby
Signed-off-by: Michael Westerhof
Tested-by: Tom King <tom@websb.net>
diff --git a/arch/arm/mach-ixp4xx/nas100d-setup.c b/arch/arm/mach-ixp4xx/nas100d-setup.c
index 54d884f..39d7d90 100644
index 213a4ce..b0884c2 100644
--- a/arch/arm/mach-ixp4xx/nas100d-setup.c
+++ b/arch/arm/mach-ixp4xx/nas100d-setup.c
@@ -21,6 +21,7 @@
@@ -12,6 +12,7 @@
*
*/
+#include <linux/if_ether.h>
#include <linux/kernel.h>
#include <linux/serial.h>
#include <linux/serial_8250.h>
@@ -21,6 +22,7 @@
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
#include <asm/mach/flash.h>
@ -10,25 +29,25 @@ index 54d884f..39d7d90 100644
static struct flash_platform_data nas100d_flash_data = {
.map_name = "cfi_probe",
@@ -125,12 +126,30 @@ static struct platform_device nas100d_uart = {
@@ -125,12 +127,30 @@ static struct platform_device nas100d_uart = {
.resource = nas100d_uart_resources,
};
+/* Built-in 10/100 Ethernet MAC interfaces */
+static struct eth_plat_info nas100d_plat_eth[] = {
+ {
+ .phy = 0,
+ .rxq = 3,
+ {
+ .phy = 0,
+ .rxq = 3,
+ .txreadyq = 20,
+ }
+ }
+};
+
+static struct platform_device nas100d_eth[] = {
+ {
+ .name = "ixp4xx_eth",
+ .id = IXP4XX_ETH_NPEB,
+ .dev.platform_data = nas100d_plat_eth,
+ }
+ {
+ .name = "ixp4xx_eth",
+ .id = IXP4XX_ETH_NPEB,
+ .dev.platform_data = nas100d_plat_eth,
+ }
+};
+
static struct platform_device *nas100d_devices[] __initdata = {
@ -41,32 +60,32 @@ index 54d884f..39d7d90 100644
};
static void nas100d_power_off(void)
@@ -146,6 +165,9 @@ static void nas100d_power_off(void)
@@ -146,6 +166,10 @@ static void nas100d_power_off(void)
static void __init nas100d_init(void)
{
+ DECLARE_MAC_BUF(mac_buf);
+ uint8_t __iomem *f;
+ int i;
+
ixp4xx_sys_init();
/* gpio 14 and 15 are _not_ clocks */
@@ -165,6 +187,33 @@ static void __init nas100d_init(void)
@@ -165,6 +189,30 @@ static void __init nas100d_init(void)
(void)platform_device_register(&nas100d_uart);
platform_add_devices(nas100d_devices, ARRAY_SIZE(nas100d_devices));
+
+
+ /*
+ * Map in a portion of the flash and read the MAC address.
+ * Since it is stored in BE in the flash itself, we need to
+ * byteswap it if we're in LE mode.
+ */
+ if ((f = ioremap(IXP4XX_EXP_BUS_BASE(0), 0x1000000))) {
+ f = ioremap(IXP4XX_EXP_BUS_BASE(0), 0x1000000);
+ if (f) {
+#ifdef __ARMEB__
+ for (i = 0; i < 6; i++) {
+ for (i = 0; i < 6; i++)
+ nas100d_plat_eth[0].hwaddr[i] = readb(f + 0xFC0FD8 + i);
+ }
+#else
+ nas100d_plat_eth[0].hwaddr[0] = readb(f + 0xFC0FD8 + 3);
+ nas100d_plat_eth[0].hwaddr[1] = readb(f + 0xFC0FD8 + 2);
@ -77,11 +96,10 @@ index 54d884f..39d7d90 100644
+#endif
+ iounmap(f);
+ }
+ printk(KERN_INFO "NAS100D: Using MAC address %.2x:%.2x:%.2x:%.2x:%.2x:%.2x for port 0\n",
+ nas100d_plat_eth[0].hwaddr[0], nas100d_plat_eth[0].hwaddr[1],
+ nas100d_plat_eth[0].hwaddr[2], nas100d_plat_eth[0].hwaddr[3],
+ nas100d_plat_eth[0].hwaddr[4], nas100d_plat_eth[0].hwaddr[5]);
+ printk(KERN_INFO "NAS100D: Using MAC address %s for port 0\n",
+ print_mac(mac_buf, nas100d_plat_eth[0].hwaddr));
+
}
MACHINE_START(NAS100D, "Iomega NAS 100d")

View File

@ -1,8 +1,27 @@
Enables the new ixp4xx qmgr and npe drivers in ixp4xx_defconfig.
Sets up the corresponding platform data for the nslu2 and nas100d
boards, and reads the ethernet MAC address from the internal flash.
Tested on both little-endian and big-endian kernels.
Signed-off-by: Rod Whitby
Signed-off-by: Michael Westerhof
Tested-by: Tom King <tom@websb.net>
diff --git a/arch/arm/mach-ixp4xx/nslu2-setup.c b/arch/arm/mach-ixp4xx/nslu2-setup.c
index 77277d2..f5e9cf7 100644
index 77277d2..332a066 100644
--- a/arch/arm/mach-ixp4xx/nslu2-setup.c
+++ b/arch/arm/mach-ixp4xx/nslu2-setup.c
@@ -24,6 +24,7 @@
@@ -14,6 +14,7 @@
* Changed to conform to new style __init ixdp425 kas11 10/22/04
*/
+#include <linux/if_ether.h>
#include <linux/kernel.h>
#include <linux/serial.h>
#include <linux/serial_8250.h>
@@ -24,6 +25,7 @@
#include <asm/mach/arch.h>
#include <asm/mach/flash.h>
#include <asm/mach/time.h>
@ -10,7 +29,7 @@ index 77277d2..f5e9cf7 100644
static struct flash_platform_data nslu2_flash_data = {
.map_name = "cfi_probe",
@@ -140,6 +141,23 @@ static struct platform_device nslu2_uart = {
@@ -140,6 +142,23 @@ static struct platform_device nslu2_uart = {
.resource = nslu2_uart_resources,
};
@ -34,7 +53,7 @@ index 77277d2..f5e9cf7 100644
static struct platform_device *nslu2_devices[] __initdata = {
&nslu2_i2c_gpio,
&nslu2_flash,
@@ -147,6 +165,7 @@ static struct platform_device *nslu2_devices[] __initdata = {
@@ -147,6 +166,7 @@ static struct platform_device *nslu2_devices[] __initdata = {
#ifdef CONFIG_LEDS_IXP4XX
&nslu2_leds,
#endif
@ -42,17 +61,18 @@ index 77277d2..f5e9cf7 100644
};
static void nslu2_power_off(void)
@@ -175,6 +194,9 @@ static struct sys_timer nslu2_timer = {
@@ -175,6 +195,10 @@ static struct sys_timer nslu2_timer = {
static void __init nslu2_init(void)
{
+ DECLARE_MAC_BUF(mac_buf);
+ uint8_t __iomem *f;
+ int i;
+
ixp4xx_sys_init();
nslu2_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
@@ -191,6 +213,33 @@ static void __init nslu2_init(void)
@@ -191,6 +215,31 @@ static void __init nslu2_init(void)
(void)platform_device_register(&nslu2_uart);
platform_add_devices(nslu2_devices, ARRAY_SIZE(nslu2_devices));
@ -63,11 +83,11 @@ index 77277d2..f5e9cf7 100644
+ * Since it is stored in BE in the flash itself, we need to
+ * byteswap it if we're in LE mode.
+ */
+ if ((f = ioremap(IXP4XX_EXP_BUS_BASE(0), 0x40000))) {
+ f = ioremap(IXP4XX_EXP_BUS_BASE(0), 0x40000);
+ if (f) {
+#ifdef __ARMEB__
+ for (i = 0; i < 6; i++) {
+ for (i = 0; i < 6; i++)
+ nslu2_plat_eth[0].hwaddr[i] = readb(f + 0x3FFB0 + i);
+ }
+#else
+ nslu2_plat_eth[0].hwaddr[0] = readb(f + 0x3FFB0 + 3);
+ nslu2_plat_eth[0].hwaddr[1] = readb(f + 0x3FFB0 + 2);
@ -78,11 +98,10 @@ index 77277d2..f5e9cf7 100644
+#endif
+ iounmap(f);
+ }
+ printk(KERN_INFO "NSLU2: Using MAC address %.2x:%.2x:%.2x:%.2x:%.2x:%.2x for port 0\n",
+ nslu2_plat_eth[0].hwaddr[0], nslu2_plat_eth[0].hwaddr[1],
+ nslu2_plat_eth[0].hwaddr[2], nslu2_plat_eth[0].hwaddr[3],
+ nslu2_plat_eth[0].hwaddr[4], nslu2_plat_eth[0].hwaddr[5]);
+ printk(KERN_INFO "NSLU2: Using MAC address %s for port 0\n",
+ print_mac(mac_buf, nslu2_plat_eth[0].hwaddr));
+
}
MACHINE_START(NSLU2, "Linksys NSLU2")

View File

@ -18,10 +18,10 @@
+ bugfix/mips/tulip_mwi_fix.patch
+ features/arm/ixp4xx-feature-bits.patch
+ features/arm/ixp4xx-npe-and-qmgr.patch
#+ features/arm/ixp4xx-net-headers.patch
+ features/arm/ixp4xx-net-headers.patch
+ features/arm/ixp4xx-net-drivers.patch
#+ features/arm/nas100d-net-driver-support.patch
#+ features/arm/nslu2-net-driver-support.patch
+ features/arm/nas100d-net-driver-support.patch
+ features/arm/nslu2-net-driver-support.patch
+ bugfix/sparc/drivers_net-broken.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch