kbuild: Fix setlocalversion invocation when objtree != srctree

svn path=/dists/trunk/linux-2.6/; revision=15962
This commit is contained in:
Ben Hutchings 2010-07-07 03:12:37 +00:00
parent 366d24b645
commit e4b386eff3
2 changed files with 29 additions and 0 deletions

View File

@ -0,0 +1,28 @@
From 9a657f2733d7ea94da555fb0c2faa16db41db885 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 7 Jul 2010 04:08:25 +0100
Subject: [PATCH] kbuild: Fix setlocalversion invocation when objtree != srctree
The scripts directory may not exist under the current directory.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
index 914e5f5..f9835c8 100644
--- a/Makefile
+++ b/Makefile
@@ -886,7 +886,7 @@ $(vmlinux-dirs): prepare scripts
# Store (new) KERNELRELASE string in include/config/kernel.release
include/config/kernel.release: include/config/auto.conf FORCE
$(Q)rm -f $@
- $(Q)echo "$(KERNELVERSION)$$($(CONFIG_SHELL) scripts/setlocalversion $(srctree))" > $@
+ $(Q)echo "$(KERNELVERSION)$$($(CONFIG_SHELL) $(srctree)/scripts/setlocalversion $(srctree))" > $@
# Things we need to do before we recursively start building the kernel
--
1.7.1

View File

@ -61,3 +61,4 @@
+ bugfix/all/ipv6-Use-interface-max_desync_factor.patch
+ bugfix/all/rtl8192su-Clean-up-in-case-of-an-error-in-mo.patch
+ bugfix/all/rtl8192su-Fix-procfs-code-for-interfaces-not.patch
+ bugfix/all/kbuild-Fix-setlocalversion-invocation.patch