Revert "linux-tools: Add version suffix to the new perf-read-vdso{,x}32 commands"

This doesn't work properly as the C macro PERF_VERSION includes the
third version component.

Also these binaries really belong under /usr/lib, not /usr/bin.

svn path=/dists/trunk/linux-tools/; revision=22601
This commit is contained in:
Ben Hutchings 2015-05-11 02:19:32 +00:00
parent 105faf0c32
commit e61262a4b0
2 changed files with 3 additions and 41 deletions

2
debian/changelog vendored
View File

@ -5,8 +5,6 @@ linux-tools (4.0.2-1) UNRELEASED; urgency=medium
to 4.0 (Closes: #778588)
* debian/control: Add gcc-multilib to Build-Depends in order to build
perf-read-vdso{,x}32
* linux-tools: Add version suffix to the new perf-read-vdso{,x}32
commands
* linux-tools: Set ARCH=x86 when building perf for amd64, i386 or x32
* linux-kbuild: Include Makefile.kasan (Closes: #783681)
* linux-kbuild: Enable Large File Support (Closes: #778942)

View File

@ -5,12 +5,11 @@ Forwarded: no
[bwh: Fix version insertion in perf man page cross-references and perf
man page title. Install bash_completion script for perf with a
version-dependent name. And do the same for trace. And the same for
perf-read-vdso{,x}32.]
version-dependent name. And do the same for trace.]
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -923,15 +923,15 @@ install-gtk:
@@ -923,8 +923,8 @@ install-gtk:
install-bin: all install-gtk
$(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
@ -20,16 +19,7 @@ perf-read-vdso{,x}32.]
+ $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)' '$(DESTDIR_SQ)$(bindir_SQ)/trace_$(VERSION)'
ifndef NO_PERF_READ_VDSO32
$(call QUIET_INSTALL, perf-read-vdso32) \
- $(INSTALL) $(OUTPUT)perf-read-vdso32 '$(DESTDIR_SQ)$(bindir_SQ)';
+ $(INSTALL) $(OUTPUT)perf-read-vdso32 '$(DESTDIR_SQ)$(bindir_SQ)/perf-read-vdso32_$(VERSION)';
endif
ifndef NO_PERF_READ_VDSOX32
$(call QUIET_INSTALL, perf-read-vdsox32) \
- $(INSTALL) $(OUTPUT)perf-read-vdsox32 '$(DESTDIR_SQ)$(bindir_SQ)';
+ $(INSTALL) $(OUTPUT)perf-read-vdsox32 '$(DESTDIR_SQ)$(bindir_SQ)/perf-read-vdsox32_$(VERSION)';
endif
$(call QUIET_INSTALL, libexec) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
$(INSTALL) $(OUTPUT)perf-read-vdso32 '$(DESTDIR_SQ)$(bindir_SQ)';
@@ -957,7 +957,7 @@ ifndef NO_LIBPYTHON
endif
$(call QUIET_INSTALL, perf_completion-script) \
@ -73,29 +63,3 @@ perf-read-vdso{,x}32.]
install-man: check-man-tools man
--- a/tools/perf/util/vdso.c
+++ b/tools/perf/util/vdso.c
@@ -22,6 +22,8 @@
*/
#include "find-vdso-map.c"
+#include "PERF-VERSION-FILE"
+
#define VDSO__TEMP_FILE_NAME "/tmp/perf-vdso.so-XXXXXX"
struct vdso_file {
@@ -51,12 +53,12 @@ static struct vdso_info *vdso_info__new(
.vdso32 = {
.temp_file_name = VDSO__TEMP_FILE_NAME,
.dso_name = DSO__NAME_VDSO32,
- .read_prog = "perf-read-vdso32",
+ .read_prog = "perf-read-vdso32_" PERF_VERSION,
},
.vdsox32 = {
.temp_file_name = VDSO__TEMP_FILE_NAME,
.dso_name = DSO__NAME_VDSOX32,
- .read_prog = "perf-read-vdsox32",
+ .read_prog = "perf-read-vdsox32_" PERF_VERSION,
},
#endif
};