aufs: Update to 3.x-rcN 20120618

svn path=/dists/trunk/linux/; revision=19271
This commit is contained in:
Ben Hutchings 2012-07-22 00:33:36 +00:00
parent bdf73892ab
commit e76e94c504
6 changed files with 405 additions and 250 deletions

2
debian/changelog vendored
View File

@ -4,7 +4,7 @@ linux (3.5-1~experimental.1) UNRELEASED; urgency=low
[ Ben Hutchings ]
* net: Enable OPENVSWITCH as module (Closes: #675010)
* aufs: Disable until it is updated for Linux 3.5
* aufs: Update to 3.x-rcN 20120618
* rt: Disable until it is updated for Linux 3.5 or later
-- Ben Hutchings <ben@decadent.org.uk> Mon, 02 Jul 2012 15:09:43 +0100

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1,23 @@
aufs3.4 base patch
aufs3.x-rcN base patch
diff --git a/fs/inode.c b/fs/inode.c
index c99163b..7f772fd 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1491,7 +1491,7 @@ static int relatime_need_update(struct vfsmount *mnt, struct inode *inode,
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
-static int update_time(struct inode *inode, struct timespec *time, int flags)
+int update_time(struct inode *inode, struct timespec *time, int flags)
{
if (inode->i_op->update_time)
return inode->i_op->update_time(inode, time, flags);
diff --git a/fs/namei.c b/fs/namei.c
index c427919..7ff959b 100644
index 7d69419..18c9782 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1831,7 +1831,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
@@ -1864,7 +1864,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -14,10 +27,10 @@ index c427919..7ff959b 100644
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
index f847684..f871233 100644
index c9f1318..490239f 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1084,8 +1084,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@@ -1086,8 +1086,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -28,7 +41,7 @@ index f847684..f871233 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -1112,9 +1112,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1114,9 +1114,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -41,6 +54,18 @@ index f847684..f871233 100644
{
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 17fd887..9c75a47 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2591,6 +2591,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
extern int inode_newsize_ok(const struct inode *, loff_t offset);
extern void setattr_copy(struct inode *inode, const struct iattr *attr);
+extern int update_time(struct inode *, struct timespec *, int);
extern int file_update_time(struct file *file);
extern int generic_show_options(struct seq_file *m, struct dentry *root);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index ffc0213..ef35a31 100644
--- a/include/linux/namei.h

View File

@ -1,4 +1,4 @@
aufs3.4 kbuild patch
aufs3.x-rcN kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index f95ae3a..6d8a9a5 100644
@ -22,7 +22,7 @@ index 2fb9779..abefac5 100644
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index 3c9b616..8704efa 100644
index 8760be3..a1b8446 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -66,6 +66,7 @@ header-y += atmppp.h

View File

@ -1,10 +1,18 @@
aufs3.4 standalone patch
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index 70f2a0f..146a3d7 100644
index a305d9e..6a768be 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -442,6 +442,8 @@ void file_sb_list_del(struct file *file)
@@ -35,6 +35,7 @@ struct files_stat_struct files_stat = {
};
DEFINE_LGLOCK(files_lglock);
+EXPORT_SYMBOL_GPL(files_lglock);
/* SLAB cache for file structures */
static struct kmem_cache *filp_cachep __read_mostly;
@@ -441,6 +442,8 @@ void file_sb_list_del(struct file *file)
}
}
@ -14,7 +22,7 @@ index 70f2a0f..146a3d7 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index 9f4f5fe..bb0f3ba 100644
index 7f772fd..e789d2f 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -56,6 +56,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@ -25,11 +33,19 @@ index 9f4f5fe..bb0f3ba 100644
/*
* Empty aops. Can be used for the cases where the user does not
@@ -1507,6 +1508,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
mark_inode_dirty_sync(inode);
return 0;
}
+EXPORT_SYMBOL_GPL(update_time);
/**
* touch_atime - update the access time
diff --git a/fs/namei.c b/fs/namei.c
index 7ff959b..b170167 100644
index 18c9782..f09edf3 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1835,6 +1835,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1868,6 +1868,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -38,10 +54,18 @@ index 7ff959b..b170167 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index e608199..38fcc2e 100644
index 1e4a5fe..06aa768 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1339,6 +1339,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -50,6 +50,7 @@ EXPORT_SYMBOL_GPL(fs_kobj);
* tree or hash is modified or when a vfsmount structure is modified.
*/
DEFINE_BRLOCK(vfsmount_lock);
+EXPORT_SYMBOL_GPL(vfsmount_lock);
static inline unsigned long hash(struct vfsmount *mnt, struct dentry *dentry)
{
@@ -1341,6 +1342,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -111,7 +135,7 @@ index f104d56..54f36db 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 5720854..ec59242 100644
index d6c79a0..9004a15 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -123,10 +147,10 @@ index 5720854..ec59242 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
index f871233..70f5481 100644
index 490239f..701d34a 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1108,6 +1108,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1110,6 +1110,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -134,7 +158,7 @@ index f871233..70f5481 100644
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -1134,6 +1135,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
@@ -1136,6 +1137,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -143,16 +167,23 @@ index f871233..70f5481 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
index 71a166a..5d63aac 100644
index 6dbae46..9f4f29a 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -972,3 +972,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
@@ -979,9 +979,11 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
+EXPORT_SYMBOL_GPL(cap_file_mmap);
+EXPORT_SYMBOL_GPL(cap_mmap_addr);
int cap_mmap_file(struct file *file, unsigned long reqprot,
unsigned long prot, unsigned long flags)
{
return 0;
}
+EXPORT_SYMBOL_GPL(cap_mmap_file);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index c43a332..0c37289 100644
index 442204c..e644a1c 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@ -163,7 +194,7 @@ index c43a332..0c37289 100644
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -499,6 +500,7 @@ found:
@@ -493,6 +494,7 @@ found:
return -EPERM;
}
@ -172,10 +203,10 @@ index c43a332..0c37289 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index bf619ff..60b996a 100644
index 3efc9b1..c7afd35 100644
--- a/security/security.c
+++ b/security/security.c
@@ -380,6 +380,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -383,6 +383,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@ -183,7 +214,7 @@ index bf619ff..60b996a 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
@@ -396,6 +397,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
@@ -399,6 +400,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@ -191,7 +222,7 @@ index bf619ff..60b996a 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
@@ -404,6 +406,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
@@ -407,6 +409,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@ -199,7 +230,7 @@ index bf619ff..60b996a 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
@@ -422,6 +425,7 @@ int security_path_truncate(struct path *path)
@@ -425,6 +428,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@ -207,7 +238,7 @@ index bf619ff..60b996a 100644
int security_path_chmod(struct path *path, umode_t mode)
{
@@ -429,6 +433,7 @@ int security_path_chmod(struct path *path, umode_t mode)
@@ -432,6 +436,7 @@ int security_path_chmod(struct path *path, umode_t mode)
return 0;
return security_ops->path_chmod(path, mode);
}
@ -215,7 +246,7 @@ index bf619ff..60b996a 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
@@ -436,6 +441,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
@@ -439,6 +444,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@ -223,7 +254,7 @@ index bf619ff..60b996a 100644
int security_path_chroot(struct path *path)
{
@@ -512,6 +518,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -515,6 +521,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@ -231,7 +262,7 @@ index bf619ff..60b996a 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
@@ -526,6 +533,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -529,6 +536,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
@ -239,7 +270,7 @@ index bf619ff..60b996a 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -641,6 +649,7 @@ int security_file_permission(struct file *file, int mask)
@@ -644,6 +652,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -247,11 +278,11 @@ index bf619ff..60b996a 100644
int security_file_alloc(struct file *file)
{
@@ -668,6 +677,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -704,6 +713,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}
+EXPORT_SYMBOL_GPL(security_file_mmap);
+EXPORT_SYMBOL_GPL(security_mmap_file);
int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
unsigned long prot)
int security_mmap_addr(unsigned long addr)
{

12
debian/patches/series vendored
View File

@ -8,14 +8,14 @@ features/all/sound-pci-cs46xx-request_firmware.patch
# Patches and source files from aufs3 repository, imported with
# debian/patches/features/all/aufs3/gen-patch.
#features/all/aufs3/aufs3-base.patch
#features/all/aufs3/aufs3-standalone.patch
#features/all/aufs3/aufs3-kbuild.patch
#features/all/aufs3/aufs3-add.patch
features/all/aufs3/aufs3-base.patch
features/all/aufs3/aufs3-standalone.patch
features/all/aufs3/aufs3-kbuild.patch
features/all/aufs3/aufs3-add.patch
# mark as staging/crap
#features/all/aufs3/mark-as-staging.patch
features/all/aufs3/mark-as-staging.patch
# fix added exports from security/device_cgroup.c
#features/all/aufs3/aufs3-fix-export-__devcgroup_inode_permission.patch
features/all/aufs3/aufs3-fix-export-__devcgroup_inode_permission.patch
bugfix/ia64/hardcode-arch-script-output.patch
bugfix/mips/disable-advansys.patch