Revert "clockevents: Set noop handler in clockevents_exchange_device()", included in stable update 3.1.5 (Closes: #653398)

svn path=/dists/sid/linux-2.6/; revision=18440
This commit is contained in:
Ben Hutchings 2011-12-30 16:52:00 +00:00
parent 5d89b7d76f
commit eace8ee92e
3 changed files with 29 additions and 0 deletions

2
debian/changelog vendored
View File

@ -12,6 +12,8 @@ linux-2.6 (3.1.6-2) UNRELEASED; urgency=low
* l2tp: ensure sk->dst is still valid (Closes: #652503)
* Update Russian debconf template translations (Yuri Kozlov)
(Closes: #653716)
* Revert "clockevents: Set noop handler in clockevents_exchange_device()",
included in stable update 3.1.5 (Closes: #653398)
[ Jonathan Nieder ]
* prerm: Print an error message when aborting removal of the running

View File

@ -0,0 +1,26 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 30 Dec 2011 17:48:49 +0100
Subject: [PATCH] Revert "clockevents: Set noop handler in
clockevents_exchange_device()"
This reverts commit aeed6baa702a285cf03b7dc4182ffc1a7f4e4ed6.
It caused some systems to hang on resume (e.g. #653398).
---
kernel/time/clockevents.c | 1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/kernel/time/clockevents.c b/kernel/time/clockevents.c
index 13dfaab..e4c699d 100644
--- a/kernel/time/clockevents.c
+++ b/kernel/time/clockevents.c
@@ -286,7 +286,6 @@ void clockevents_exchange_device(struct clock_event_device *old,
* released list and do a notify add later.
*/
if (old) {
- old->event_handler = clockevents_handle_noop;
clockevents_set_mode(old, CLOCK_EVT_MODE_UNUSED);
list_del(&old->list);
list_add(&old->list, &clockevents_released);
--
1.7.7.3

View File

@ -93,3 +93,4 @@
+ bugfix/all/net-introduce-DST_NOPEER-dst-flag.patch
+ bugfix/all/rtc-Fix-alarm-rollover-when-day-or-month-is-out-of-r.patch
+ bugfix/all/l2tp-ensure-sk-dst-is-still-valid.patch
+ bugfix/all/revert-clockevents-Set-noop-handler-in-clockevents_e.patch