Merge changes from sid up to 3.13.10-1

svn path=/dists/trunk/linux/; revision=21240
This commit is contained in:
Ben Hutchings 2014-04-16 12:25:45 +00:00
commit ebb94e764b
3 changed files with 149 additions and 0 deletions

82
debian/changelog vendored
View File

@ -61,6 +61,88 @@ linux (3.14~rc5-1~exp1) experimental; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Fri, 07 Mar 2014 03:36:35 +0000
linux (3.13.10-1) unstable; urgency=medium
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.8
- ALSA: compress: Pass through return value of open ops callback
- [hppa] partly revert commit 8a10bc9: parisc/sti_console: prefer Linux
fonts over built-in ROM fonts (regression in 3.13.2)
- [armhf] net: davinci_emac: Replace devm_request_irq with request_irq
(regression in 3.11)
- NFSv4: Use the correct net namespace in nfs4_update_server
- media: cxusb: unlock on error in cxusb_i2c_xfer() (regression in 3.13)
- media: dw2102: some missing unlocks on error (regression in 3.13)
- libceph: block I/O when PAUSE or FULL osd map flags are set
- libceph: resend all writes after the osdmap loses the full flag
- stop_machine: Fix^2 race between stop_two_cpus() and stop_cpus()
- [arm] 7941/2: Fix incorrect FDT initrd parameter override
(regression in 3.13)
- [x86] bpf_jit: support negative offsets
- printk: fix syslog() overflowing user buffer
- Fix uses of dma_max_pfn() when converting to a limiting address
- deb-pkg: Fix building for MIPS big-endian or ARM OABI
- deb-pkg: Fix cross-building linux-headers package
- fs/proc/proc_devtree.c: remove empty /proc/device-tree when no
openfirmware exists.
- KVM: MMU: handle invalid root_hpa at __direct_map
- [x86] KVM: x86: handle invalid root_hpa everywhere
- KVM: VMX: fix use after free of vmx->loaded_vmcs
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.9
- ext4: atomically set inode->i_flags in ext4_set_inode_flags()
- rcuwalk: recheck mount_lock after mountpoint crossing attempts
- Input: mousedev - fix race when creating mixed device
- xen/balloon: flush persistent kmaps in correct position
- Revert "xen: properly account for _PAGE_NUMA during xen pte translations"
(regression in 3.13.5)
- drm/i915: Undo gtt scratch pte unmapping again (regression in 3.12)
- [i386/486] fix boot on uniprocessor systems
- random32: avoid attempt to late reseed if in the middle of seeding
- rcuwalk: switch mnt_hash to hlist
- mm: close PageTail race
- cgroup: protect modifications to cgroup_idr with cgroup_mutex
- netfilter: nf_conntrack_dccp: fix skb_header_pointer API usages
(CVE-2014-2523)
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.10
- selinux: correctly label /proc inodes in use before the policy is loaded
- net: sctp: fix skb leakage in COOKIE ECHO path of chunk->auth_chunk
- bridge: multicast: add sanity check for query source addresses
- tipc: allow connection shutdown callback to be invoked in advance
- tipc: fix connection refcount leak
- tipc: drop subscriber connection id invalidation
- inet: frag: make sure forced eviction removes all frags
- vlan: Set correct source MAC address with TX VLAN offload enabled
(regression in 3.13)
- tcp: tcp_release_cb() should release socket ownership
- bridge: multicast: add sanity check for general query destination
- bridge: multicast: enable snooping on general queries only
- net: socket: error on a negative msg_namelen (regression in 3.11.10)
- bonding: set correct vlan id for alb xmit path (regression in 3.12)
- ipv6: Avoid unnecessary temporary addresses being generated
- net: cdc_ncm: fix control message ordering (regression in 3.13)
- tcp: syncookies: do not use getnstimeofday() (regression in 3.13)
- tipc: fix spinlock recursion bug for failed subscriptions
- ip_tunnel: Fix dst ref-count. (regression in 3.13.7)
- tg3: Do not include vlan acceleration features in vlan_features
- virtio-net: correct error handling of virtqueue_kick()
(regression in 3.13)
- usbnet: include wait queue head in device structure
- vhost: fix total length when packets are too short (CVE-2014-0077)
- vhost: validate vhost_get_vq_desc return value (CVE-2014-0055)
- tcp: fix get_timewait4_sock() delay computation on 64bit
(regression in 3.13)
- xen-netback: remove pointless clause from if statement
- netlink: don't compare the nul-termination in nla_strcmp
- xen-netback: disable rogue vif in kthread context
- net: vxlan: fix crash when interface is created with no group
- rds: prevent dereference of a NULL device in rds_iw_laddr_check
(CVE-2014-2678)
- powernow-k6: disable cache when changing frequency
- [m68k] Skip futex_atomic_cmpxchg_inatomic() test
- crypto: ghash-clmulni-intel - use C implementation for setkey()
-- Ben Hutchings <ben@decadent.org.uk> Tue, 15 Apr 2014 22:12:38 +0100
linux (3.13.7-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 15 Apr 2014 22:05:04 +0100
Subject: trace: Avoid ABI change in 3.13.8
Forwarded: not-needed
--- a/kernel/trace/trace_events.c
+++ b/kernel/trace/trace_events.c
@@ -27,6 +27,12 @@
DEFINE_MUTEX(event_mutex);
+/* Should no longer be used, but kept for compatibility with older modules */
+DEFINE_MUTEX(event_storage_mutex);
+EXPORT_SYMBOL_GPL(event_storage_mutex);
+char event_storage[128];
+EXPORT_SYMBOL_GPL(event_storage);
+
LIST_HEAD(ftrace_events);
static LIST_HEAD(ftrace_common_fields);

View File

@ -0,0 +1,47 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 15 Apr 2014 21:56:00 +0100
Subject: vfs: Avoid ABI change in 3.13.9
Forwarded: not-needed
--- a/fs/mount.h
+++ b/fs/mount.h
@@ -18,14 +18,27 @@ struct mnt_pcp {
int mnt_writers;
};
+/*
+ * These structures are not exposed to modules, but changes somehow
+ * still affect exported symbol versions!
+ */
+
struct mountpoint {
+#ifdef __GENKSYMS__
+ struct list_head m_hash; /* not really */
+#else
struct hlist_node m_hash;
+#endif
struct dentry *m_dentry;
int m_count;
};
struct mount {
+#ifdef __GENKSYMS__
+ struct list_head mnt_hash; /* not really */
+#else
struct hlist_node mnt_hash;
+#endif
struct mount *mnt_parent;
struct dentry *mnt_mountpoint;
struct vfsmount mnt;
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -23,7 +23,9 @@
#include <linux/uaccess.h>
#include <linux/proc_ns.h>
#include <linux/magic.h>
+#ifndef __GENKSYMS__
#include <linux/bootmem.h>
+#endif
#include "pnode.h"
#include "internal.h"