Add bugfix/sunhme-pci-enable.patch, fixing the failure of sunhme

drivers on x86 hosts due to missing pci_enable_device() and 
pci_set_master() calls, lost during code refactoring.

svn path=/dists/sid/linux-2.6/; revision=7923
This commit is contained in:
Jurij Smakov 2006-12-03 23:36:58 +00:00
parent cc60dd7b29
commit f77bad895e
3 changed files with 22 additions and 0 deletions

6
debian/changelog vendored
View File

@ -16,6 +16,12 @@ linux-2.6 (2.6.18-7) UNRELEASED; urgency=low
* sata: Avoid null pointer dereference in SATA Promise.
* cifs: Set CIFS preferred IO size.
[ Jurij Smakov ]
* Add bugfix/sunhme-pci-enable.patch, fixing the failure of sunhme
driver on x86/PCI hosts due to missing pci_enable_device() and
pci_set_master() calls, lost during code refactoring upstream.
(closes: #397460)
-- Bastian Blank <waldi@debian.org> Sat, 2 Dec 2006 10:40:12 +0100
linux-2.6 (2.6.18-6) unstable; urgency=low

View File

@ -0,0 +1,15 @@
diff -aur a/drivers/net/sunhme.c b/drivers/net/sunhme.c
--- a/drivers/net/sunhme.c 2006-11-18 19:28:22.000000000 -0800
+++ b/drivers/net/sunhme.c 2006-11-23 10:36:36.000000000 -0800
@@ -3012,6 +3012,11 @@
#endif
err = -ENODEV;
+
+ if (pci_enable_device(pdev))
+ goto err_out;
+ pci_set_master(pdev);
+
if (!strcmp(prom_name, "SUNW,qfe") || !strcmp(prom_name, "qfe")) {
qp = quattro_pci_find(pdev);
if (qp == NULL)

View File

@ -3,3 +3,4 @@
+ bugfix/fs-hfs-mokb.patch
+ bugfix/sata-promise-null-deref.patch
+ bugfix/s390/include-asm-posix_types.patch
+ bugfix/sunhme-pci-enable.patch