linux/debian/patches-rt/0272-Revert-futex-Ensure-lo...

39 lines
1.4 KiB
Diff

From 6f1cd1d4fc326ff505151c9cea6df15f8a322b4e Mon Sep 17 00:00:00 2001
Message-Id: <6f1cd1d4fc326ff505151c9cea6df15f8a322b4e.1601675153.git.zanussi@kernel.org>
In-Reply-To: <5b5a156f9808b1acf1205606e03da117214549ea.1601675151.git.zanussi@kernel.org>
References: <5b5a156f9808b1acf1205606e03da117214549ea.1601675151.git.zanussi@kernel.org>
From: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
Date: Wed, 26 Jun 2019 17:44:13 +0200
Subject: [PATCH 272/333] Revert "futex: Ensure lock/unlock symetry versus
pi_lock and hash bucket lock"
Origin: https://www.kernel.org/pub/linux/kernel/projects/rt/4.19/older/patches-4.19.148-rt64.tar.xz
[ Upstream commit 6a773b70cf105b46298ed3b44e77c102ce31d9ec ]
Drop the RT fixup, the futex code will be changed to avoid the need for
the workaround.
Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
kernel/futex.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/kernel/futex.c b/kernel/futex.c
index 084527af43d4..b99266393c52 100644
--- a/kernel/futex.c
+++ b/kernel/futex.c
@@ -938,9 +938,7 @@ void exit_pi_state_list(struct task_struct *curr)
if (head->next != next) {
/* retain curr->pi_lock for the loop invariant */
raw_spin_unlock(&pi_state->pi_mutex.wait_lock);
- raw_spin_unlock_irq(&curr->pi_lock);
spin_unlock(&hb->lock);
- raw_spin_lock_irq(&curr->pi_lock);
put_pi_state(pi_state);
continue;
}
--
2.17.1