linux/debian/patches/bugfix/all/stable/2.6.32.15.patch

33 lines
1.0 KiB
Diff

diff --git a/Makefile b/Makefile
index 47866f8..36fead3 100644
diff --git a/kernel/lockdep.c b/kernel/lockdep.c
index f672d51..9af5672 100644
--- a/kernel/lockdep.c
+++ b/kernel/lockdep.c
@@ -591,9 +591,9 @@ static int static_obj(void *obj)
* percpu var?
*/
for_each_possible_cpu(i) {
- start = (unsigned long) per_cpu_ptr(&__per_cpu_start, i);
- end = (unsigned long) per_cpu_ptr(&__per_cpu_start, i)
- + PERCPU_ENOUGH_ROOM;
+ start = (unsigned long) &__per_cpu_start + per_cpu_offset(i);
+ end = (unsigned long) &__per_cpu_start + PERCPU_ENOUGH_ROOM
+ + per_cpu_offset(i);
if ((addr >= start) && (addr < end))
return 1;
diff --git a/kernel/module.c b/kernel/module.c
index a4aae35..dfa33e8 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -555,7 +555,7 @@ static void percpu_modcopy(void *pcpudest, const void *from, unsigned long size)
int cpu;
for_each_possible_cpu(cpu)
- memcpy(per_cpu_ptr(pcpudest, cpu), from, size);
+ memcpy(pcpudest + per_cpu_offset(cpu), from, size);
}
#else /* ... !CONFIG_SMP */