linux/debian/patches/features/all/r8723au/0090-staging-rtl8723au-Add-...

28 lines
1.1 KiB
Diff

From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: Wed, 11 Jun 2014 16:57:46 +0200
Subject: [090/249] staging: rtl8723au: Add compiler check for -Wtype-limits
Origin: https://git.kernel.org/linus/ee264346fa08395aa6e846b72e7b3987e959f053
Gcc versions before 4.3 do not support -Wtype-limits:
cc1: error: unrecognized command line option "-Wtype-limits"
Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
Acked-by: Jes Sorensen <Jes.Sorensen@redhat.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
drivers/staging/rtl8723au/Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723au/Makefile b/drivers/staging/rtl8723au/Makefile
index 6f76c7b..a9aae21 100644
--- a/drivers/staging/rtl8723au/Makefile
+++ b/drivers/staging/rtl8723au/Makefile
@@ -52,4 +52,5 @@ r8723au-$(CONFIG_8723AU_AP_MODE) += core/rtw_ap.o
obj-$(CONFIG_R8723AU) := r8723au.o
-ccflags-y += -Wtype-limits -D__CHECK_ENDIAN__ -I$(src)/include
+ccflags-y += $(call cc-option,-Wtype-limits,)
+ccflags-y += -D__CHECK_ENDIAN__ -I$(src)/include