linux/debian/patches/features/all/aufs2/aufs2-kbuild.patch

36 lines
976 B
Diff

aufs2.1 kbuild patch for linux-2.6.
diff --git a/fs/Kconfig b/fs/Kconfig
index 3db9caa..c9e1f11 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -190,6 +190,7 @@ source "fs/romfs/Kconfig"
source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig"
+source "fs/aufs/Kconfig"
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index a7f7cef..95dd4d3 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -121,3 +121,4 @@ obj-$(CONFIG_BTRFS_FS) += btrfs/
obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-$(CONFIG_CEPH_FS) += ceph/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index b0ada6f..5cb5837 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -64,6 +64,7 @@ header-y += atmppp.h
header-y += atmsap.h
header-y += atmsvc.h
header-y += audit.h
+header-y += aufs_type.h
header-y += auto_fs.h
header-y += auto_fs4.h
header-y += auxvec.h