generic-poky/meta/recipes-graphics/xorg-lib/libxpm_3.5.10.bb

29 lines
766 B
BlitzBasic

require xorg-lib-common.inc
# libxpm requires xgettext to build
inherit gettext
SUMMARY = "Xpm: X Pixmap extension library"
DESCRIPTION = "libXpm provides support and common operation for the XPM \
pixmap format, which is commonly used in legacy X applications. XPM is \
an extension of the monochrome XBM bitmap specificied in the X \
protocol."
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=3e07763d16963c3af12db271a31abaa5"
DEPENDS += "libxext libsm libxt"
PR = "r0"
PE = "1"
XORG_PN = "libXpm"
PACKAGES =+ "sxpm cxpm"
FILES_cxpm = "${bindir}/cxpm"
FILES_sxpm = "${bindir}/sxpm"
SRC_URI[md5sum] = "7ae7eff7a14d411e84a67bd166bcec1a"
SRC_URI[sha256sum] = "a6db7e234750e7d60330017972e31d8e1f29f0a8c1391e4ac82f6102d919a735"
BBCLASSEXTEND = "native"