generic-poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.9.bb

33 lines
1.1 KiB
BlitzBasic

SUMMARY = "Keyboard configuration database for X Window"
DESCRIPTION = "The non-arch keyboard configuration database for X \
Window. The goal is to provide the consistent, well-structured, \
frequently released open source of X keyboard configuration data for X \
Window System implementations. The project is targeted to XKB-based \
systems."
HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
LICENSE = "MIT & MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
SRC_URI="${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
SRC_URI[md5sum] = "9b1280d8ba40274a0f1567c94fca7501"
SRC_URI[sha256sum] = "5e89bc182a10d53c3e83efc6c3546de0fe5504d91c3dbc80d55cc64ddab5643a"
SECTION = "x11/libs"
DEPENDS = "intltool-native virtual/gettext util-macros"
EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
FILES_${PN} += "${datadir}/X11/xkb"
inherit autotools pkgconfig
do_install_append () {
install -d ${D}${datadir}/X11/xkb/compiled
cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
}