generic-poky/meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff

44 lines
1.2 KiB
Diff

Subject: Postpone LD_LIBRARY_PATH evaluation to the binary targets.
Modify the setting of LD_LIBRARY_PATH to append pre-existing values at the
time the rule is evaluated rather than when the Makefile is created.
This is required when building packages with dpkg-buildpackage and fakeroot,
since fakeroot (which now sets LD_LIBRARY_PATH) is not used for the "build"
rule where the Makefile is created, but is for the clean/binary* targets.
---
Makefile.SH | 9 ++-------
1 files changed, 2 insertions(+), 7 deletions(-)
diff --git a/Makefile.SH b/Makefile.SH
index c039938..15184d8 100755
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -50,12 +50,7 @@ case "$useshrplib" in
true)
# Prefix all runs of 'miniperl' and 'perl' with
# $ldlibpth so that ./perl finds *this* shared libperl.
- case "$LD_LIBRARY_PATH" in
- '')
- ldlibpth="LD_LIBRARY_PATH=`pwd`";;
- *)
- ldlibpth="LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}";;
- esac
+ ldlibpth=LD_LIBRARY_PATH=`pwd`'$${LD_LIBRARY_PATH:+:}$$LD_LIBRARY_PATH'
pldlflags="$cccdlflags"
static_ldflags=''
@@ -126,7 +121,7 @@ true)
;;
esac
case "$ldlibpthname" in
- '') ;;
+ ''|LD_LIBRARY_PATH) ;;
*)
case "$osname" in
os2)
--
tg: (c823880..) debian/fakeroot (depends on: upstream)