generic-poky/meta/recipes-devtools/perl/perl-5.12.2/debian/cpanplus_config_path.diff
Nitin A Kamble f57e9daf74 perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now.
    deleted:    files/perl-5.8.8-gcc-4.2.patch
    deleted:    perl-5.12.2/makedepend-dash.patch
    deleted:    perl-5.12.2/native-no-gdbminc.patch
    deleted:    perl-5.12.2/54_debian_perldoc-r.patch

And rebased these patches to the newer source code
    modified:   files/letgcc-find-errno.patch
    modified:   perl-5.12.2/Makefile.patch
    modified:   perl-5.12.2/asm-pageh-fix.patch
    modified:   perl-5.12.2/native-nopacklist.patch
    modified:   perl-5.12.2/native-perlinc.patch
    modified:   perl-5.12.2/Makefile.SH.patch
    modified:   perl-5.12.2/installperl.patch
    modified:   perl-5.12.2/perl-dynloader.patch
    modified:   perl-5.12.2/09_fix_installperl.patch

get patches from debian perl ver 5.12.2-2
   the fakeroot.diff patch from debian is conflicting with our
   Makefile.SH.patch, hence disabling the fakeroot patch

use newly created config files
   Created with current milestone branch on qemu machines
      modified:   config.sh
      modified:   config.sh-32
      modified:   config.sh-64

get some changes from oe's perl 5.10.1 recipe
   fix the Makefile.SH.patch use miniperl instead of perl
   import a OE 5.10.1 patch: uudmap_cross

fix install issues
   add /usr in the destdir, so that perl gets installed in
   /usr/bin/perl and not in /bin/perl

   link /usr/lib/perl to /usr/lib/perl5 so that operations with
   /usr/lib/perl path in them keep on working.

Fix/Improve perl packaging
   avoid perl-module-module-* kind of packages
   recreate perl-rdepends_5.12.2.inc file with new set of packages
   import from oe perl-rprovide_5.12.2.inc
   combine all unicore perl scripts in one package
   simplify perl-lib
   reduce no of perl recipe packages greatly.

Add zlib to depedancy

fix buildtime host contamination

This also fixes [BUGID #384]

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
2011-01-12 00:55:48 -08:00

44 lines
1.9 KiB
Diff

From: Niko Tyni <ntyni@debian.org>
Subject: Save local versions of CPANPLUS::Config::System into /etc/perl.
This is a configuration file and needs to go in /etc by policy.
Besides, /usr may not even be writable.
This mirrors the Debian setup of CPAN.pm in debian/cpan_config_path.
See #533707.
---
cpan/CPANPLUS/lib/CPANPLUS/Configure.pm | 1 +
cpan/CPANPLUS/lib/CPANPLUS/Internals/Constants.pm | 3 +++
2 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/cpan/CPANPLUS/lib/CPANPLUS/Configure.pm b/cpan/CPANPLUS/lib/CPANPLUS/Configure.pm
index baac91d..a3794de 100644
--- a/cpan/CPANPLUS/lib/CPANPLUS/Configure.pm
+++ b/cpan/CPANPLUS/lib/CPANPLUS/Configure.pm
@@ -276,6 +276,7 @@ Saves the configuration to the package name you provided.
If this package is not C<CPANPLUS::Config::System>, it will
be saved in your C<.cpanplus> directory, otherwise it will
be attempted to be saved in the system wide directory.
+(On Debian systems, this system wide directory is /etc/perl.)
If no argument is provided, it will default to your personal
config.
diff --git a/cpan/CPANPLUS/lib/CPANPLUS/Internals/Constants.pm b/cpan/CPANPLUS/lib/CPANPLUS/Internals/Constants.pm
index 1a38200..6ee0d82 100644
--- a/cpan/CPANPLUS/lib/CPANPLUS/Internals/Constants.pm
+++ b/cpan/CPANPLUS/lib/CPANPLUS/Internals/Constants.pm
@@ -199,6 +199,9 @@ use constant CONFIG_USER_FILE => sub {
) . '.pm';
};
use constant CONFIG_SYSTEM_FILE => sub {
+ # Debian-specific shortcut
+ return '/etc/perl/CPANPLUS/Config/System.pm';
+
require CPANPLUS::Internals;
require File::Basename;
my $dir = File::Basename::dirname(
--
tg: (c823880..) debian/cpanplus_config_path (depends on: upstream)