generic-poky/meta/recipes-devtools/perl/perl-5.14.3/debian/fakeroot.diff

46 lines
1.4 KiB
Diff

Upstream-Status:Inappropriate [debian patches]
From a46a7107fb045ffa6047488b8002fec97b621a11 Mon Sep 17 00:00:00 2001
From: Brendan O'Dea <bod@debian.org>
Date: Fri, 18 Mar 2005 22:22:25 +1100
Subject: Postpone LD_LIBRARY_PATH evaluation to the binary targets.
Modify the setting of LD_LIBRARY_PATH to append pre-existing values at the
time the rule is evaluated rather than when the Makefile is created.
This is required when building packages with dpkg-buildpackage and fakeroot,
since fakeroot (which now sets LD_LIBRARY_PATH) is not used for the "build"
rule where the Makefile is created, but is for the clean/binary* targets.
Patch-Name: debian/fakeroot.diff
---
Makefile.SH | 9 ++-------
1 files changed, 2 insertions(+), 7 deletions(-)
diff --git a/Makefile.SH b/Makefile.SH
index eb6326a..1dac585 100755
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -36,12 +36,7 @@ case "$useshrplib" in
true)
# Prefix all runs of 'miniperl' and 'perl' with
# $ldlibpth so that ./perl finds *this* shared libperl.
- case "$LD_LIBRARY_PATH" in
- '')
- ldlibpth="LD_LIBRARY_PATH=`pwd`";;
- *)
- ldlibpth="LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}";;
- esac
+ ldlibpth=LD_LIBRARY_PATH=`pwd`'$${LD_LIBRARY_PATH:+:}$$LD_LIBRARY_PATH'
pldlflags="$cccdlflags"
static_ldflags=''
@@ -112,7 +107,7 @@ true)
;;
esac
case "$ldlibpthname" in
- '') ;;
+ ''|LD_LIBRARY_PATH) ;;
*)
case "$osname" in
os2)