generic-poky/meta/packages/libgpg-error/libgpg-error-1.0/pkgconfig.patch

57 lines
2.0 KiB
Diff

#
# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
#
Index: libgpg-error-1.0/configure.ac
===================================================================
--- libgpg-error-1.0.orig/configure.ac 2004-07-30 07:48:04.000000000 -0500
+++ libgpg-error-1.0/configure.ac 2005-02-23 18:52:01.000000000 -0600
@@ -83,6 +83,7 @@
AC_SUBST(GPG_ERROR_CONFIG_LIBS)
AC_SUBST(GPG_ERROR_CONFIG_CFLAGS)
AC_CONFIG_FILES([src/gpg-error-config], [chmod +x src/gpg-error-config])
+AC_CONFIG_FILES([src/gpg-error.pc])
# Checks for library functions.
AC_CONFIG_FILES([Makefile])
Index: libgpg-error-1.0/src/Makefile.am
===================================================================
--- libgpg-error-1.0.orig/src/Makefile.am 2004-06-28 07:37:38.000000000 -0500
+++ libgpg-error-1.0/src/Makefile.am 2005-02-23 18:53:57.000000000 -0600
@@ -24,7 +24,8 @@
mkerrnos.awk errnos.in \
mkerrcodes.awk mkerrcodes1.awk mkerrcodes2.awk mkerrcodes.c \
mkheader.awk gpg-error.h.in \
- err-sources.h err-codes.h gpg-error-config.in gpg-error.m4
+ err-sources.h err-codes.h gpg-error-config.in gpg-error.m4 \
+ gpg-error.pc.in
BUILT_SOURCES = err-sources.h err-codes.h code-to-errno.h code-from-errno.h \
err-sources-sym.h err-codes-sym.h errnos-sym.h gpg-error.h
@@ -39,6 +40,9 @@
m4datadir = $(datadir)/aclocal
m4data_DATA = gpg-error.m4
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gpg-error.pc
+
include_HEADERS = gpg-error.h
lib_LTLIBRARIES = libgpg-error.la
Index: libgpg-error-1.0/src/gpg-error.pc.in
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ libgpg-error-1.0/src/gpg-error.pc.in 2005-02-23 18:52:01.000000000 -0600
@@ -0,0 +1,10 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: gpg-error
+Description: a library that defines common error values for all GnuPG components
+Version: @VERSION@
+Libs: -L{libdir} -lgpg-error
+Cflags: -I${includedir}