generic-poky/meta/packages/alsa/alsa-utils-1.0.23/ncursesfix.patch

43 lines
1.7 KiB
Diff

# alsa-utils: Fix ncurses build failures
# Richard Purdie <rpurdie@linux.intel.com>
# Rebased to 1.0.23, Dongxiao Xu <dongxiao.xu@intel.com>
diff -ruN alsa-utils-1.0.23-orig/configure.in alsa-utils-1.0.23/configure.in
--- alsa-utils-1.0.23-orig/configure.in 2010-04-16 19:19:12.000000000 +0800
+++ alsa-utils-1.0.23/configure.in 2010-06-22 15:22:06.731202478 +0800
@@ -109,34 +109,16 @@
NCURSESLIBSUFFIX=""
CURSES_NLS="no"
if test "$curseslib" = "ncursesw" -o \( "$curseslib" = "auto" -a "$USE_NLS" = "yes" \); then
- AC_CHECK_PROG([ncursesw5_config], [ncursesw5-config], [yes])
- if test "$ncursesw5_config" = "yes"; then
- CURSESINC="<ncurses.h>"
- CURSESLIB=`ncursesw5-config --libs`
- CURSESLIBDIR=`ncursesw5-config --libdir`
- CURSES_CFLAGS=`ncursesw5-config --cflags`
- curseslib="ncursesw"
- else
AC_CHECK_LIB(ncursesw, initscr,
[ CURSESINC='<ncurses.h>'; CURSESLIB='-lncursesw'; curseslib="ncursesw"])
- fi
if test -n "$CURSESINC"; then
NCURSESLIBSUFFIX="w"
CURSES_NLS="yes"
fi
fi
if test "$curseslib" = "ncurses" -o "$curseslib" = "auto"; then
- AC_CHECK_PROG([ncurses5_config], [ncurses5-config], [yes])
- if test "$ncurses5_config" = "yes"; then
- CURSESINC="<ncurses.h>"
- CURSESLIB=`ncurses5-config --libs`
- CURSESLIBDIR=`ncurses5-config --libdir`
- CURSES_CFLAGS=`ncurses5-config --cflags`
- curseslib="ncurses"
- else
AC_CHECK_LIB(ncurses, initscr,
[ CURSESINC='<ncurses.h>'; CURSESLIB='-lncurses'; curseslib="ncurses"])
- fi
fi
if test "$curseslib" = "curses" -o "$curseslib" = "auto"; then
AC_CHECK_LIB(curses, initscr,