iperf: Upgrade to 2.0.9 to solve c++ compilation issue

2.0.5 is known not to build with newer G++/libstdc++. Upgrade to
version 2.0.9, fix compilation issue on arm for C code and let's
see..
This commit is contained in:
Holger Hans Peter Freyther 2017-04-07 10:36:19 +02:00
parent 2b8949c52e
commit 789c9a650c
3 changed files with 18 additions and 13 deletions

View File

@ -1,8 +0,0 @@
diff --git iperf-2.0.5/man/Makefile.am iperf-2.0.5/man/Makefile.am
index ed97bc6..728873f 100644
--- iperf-2.0.5/man/Makefile.am
+++ iperf-2.0.5/man/Makefile.am
@@ -1,2 +1 @@
-man_MANS = iperf.1
-dist_man_MANS = $(man_MANS)
+dist_man_MANS = iperf.1

View File

@ -0,0 +1,13 @@
Index: iperf-2.0.9/include/util.h
===================================================================
--- iperf-2.0.9.orig/include/util.h
+++ iperf-2.0.9/include/util.h
@@ -57,6 +57,8 @@
#include "config.h"
#endif
+#include <stdbool.h>
+
#ifdef __cplusplus
extern "C" {
#endif

View File

@ -4,12 +4,12 @@ SECTION = "console/network"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
SRC_URI = " ${SOURCEFORGE_MIRROR}/iperf/${PN}-${PV}.tar.gz \
file://iperf-2.0.5_ManPage.patch \
"
SRC_URI = "${SOURCEFORGE_MIRROR}/iperf2/${PN}-${PV}.tar.gz \
file://stdbool-compilation.patch \
"
SRC_URI[md5sum] = "44b5536b67719f4250faed632a3cd016"
SRC_URI[sha256sum] = "636b4eff0431cea80667ea85a67ce4c68698760a9837e1e9d13096d20362265b"
SRC_URI[md5sum] = "351b018b71176b8cb25f20eef6a9e37c"
SRC_URI[sha256sum] = "db02911f35686e808ed247160dfa766e08ae3f59d1e7dcedef0ffb2a6643f0bf"
S = "${WORKDIR}/${PN}-${PV}"