edison: Remove edison support from meta-sysmocom-bsp

This means that currently only Yocto Dora and Yocto Master are
being targeted. The amount of maintenance to get it to work on
Edison again is too high and it is better to focus on a systemd
only world. Remove the symlinks for yocto-edison.

A quick look and some notes from henning pointed me to wget
which is in the default layers, the sysmobts-2050 which is now
handle dby sysmobts and some older notes that are unlikely
to be addressed.
This commit is contained in:
Holger Hans Peter Freyther 2015-02-13 00:40:34 +01:00
parent 53c20998d8
commit 8f8dae9938
16 changed files with 1 additions and 132 deletions

View File

@ -9,7 +9,7 @@ BBFILES += "${LAYERDIR}/yocto-shared/*.bbappend"
BBFILES += "${BBFILES_SYSMOCOM_BSP}"
# selects specific distro or master when DISTRO_VERSION contains snapshot
BBFILES_SYSMOCOM_BSP = "${LAYERDIR}/yocto-${@ [dict([('1.5', 'dora'), ('1.1','edison'), ('1.7', 'dizzy')])[d.getVar('DISTRO_VERSION', True)[0:3]], 'master']['snapshot' in d.getVar('DISTRO_VERSION', True)]}/*.bbappend"
BBFILES_SYSMOCOM_BSP = "${LAYERDIR}/yocto-${@ [dict([('1.5', 'dora'), ('1.7', 'dizzy')])[d.getVar('DISTRO_VERSION', True)[0:3]], 'master']['snapshot' in d.getVar('DISTRO_VERSION', True)]}/*.bbappend"
BBFILE_COLLECTIONS += "sysmocom-bsp"
BBFILE_PATTERN_sysmocom-bsp := "^${LAYERDIR}/"

View File

@ -1,18 +0,0 @@
#@TYPE: Machine
#@NAME: sysmoBTS 2050
#@DESCRIPTION: sysmocom GmbH sysmoBTS 2050 family
require sysmobts-v2.conf
MACHINEOVERRIDES = "${MACHINE}:sysmobts-v2"
# TODO: Remove this file once edison support is dropped from this layer
# we are disabling the serial console for now, as it may interfere with
# the MSP430 service processor communication until proper filtering/splitting
# of the serial stream is implemented in the kernel
SERIAL_CONSOLE = ""
# we don't want a different UBIfs volume name, as this is compiled into u-boot,
# and thus would require a different u-boot image in turn.
UBI_VOLNAME="sysmobts-v2-rootfs"

View File

@ -1,4 +1,3 @@
# TODO: When dropping netbase for edison we can rename it
SYSMOCOM := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
FILESEXTRAPATHS_prepend := "${SYSMOCOM}/netbase-${PV}:${SYSMOCOM}/netbase:"
PRINC = "4"

View File

@ -1,59 +0,0 @@
Upstream-Status: Pending
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Index: wget-1.12/po/Makefile.in.in
===================================================================
--- wget-1.12.orig/po/Makefile.in.in 2009-09-04 09:31:54.000000000 -0700
+++ wget-1.12/po/Makefile.in.in 2011-10-19 20:32:53.714812160 -0700
@@ -8,8 +8,8 @@
# Please note that the actual code of GNU gettext is covered by the GNU
# General Public License and is *not* in the public domain.
#
-# Origin: gettext-0.17
-GETTEXT_MACRO_VERSION = 0.17
+# Origin: gettext-0.18
+GETTEXT_MACRO_VERSION = 0.18
PACKAGE = @PACKAGE@
VERSION = @VERSION@
Index: wget-1.12/configure.ac
===================================================================
--- wget-1.12.orig/configure.ac 2009-09-22 09:39:49.000000000 -0700
+++ wget-1.12/configure.ac 2011-10-19 20:32:53.714812160 -0700
@@ -110,7 +110,7 @@
dnl Gettext
dnl
AM_GNU_GETTEXT([external],[need-ngettext])
-AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT_VERSION([0.18])
AC_PROG_RANLIB
Index: wget-1.12/configure
===================================================================
--- wget-1.12.orig/configure 2009-09-22 09:40:13.000000000 -0700
+++ wget-1.12/configure 2011-10-19 20:33:46.578812174 -0700
@@ -5297,7 +5297,7 @@
- GETTEXT_MACRO_VERSION=0.17
+ GETTEXT_MACRO_VERSION=0.18
Index: wget-1.12/m4/po.m4
===================================================================
--- wget-1.12.orig/m4/po.m4 2009-09-04 09:31:54.000000000 -0700
+++ wget-1.12/m4/po.m4 2011-10-19 20:33:53.426812176 -0700
@@ -30,7 +30,7 @@
dnl Release version of the gettext macros. This is used to ensure that
dnl the gettext macros and po/Makefile.in.in are in sync.
- AC_SUBST([GETTEXT_MACRO_VERSION], [0.17])
+ AC_SUBST([GETTEXT_MACRO_VERSION], [0.18])
dnl Perform the following tests also if --disable-nls has been given,
dnl because they are needed for "make dist" to work.

View File

@ -1,20 +0,0 @@
DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
SECTION = "console/network"
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "openssl"
INC_PR = "r13"
inherit autotools gettext update-alternatives
EXTRA_OECONF = "--with-libc --enable-ipv6 --with-libssl-prefix=${STAGING_DIR_HOST} --with-ssl=openssl"
do_install_append () {
mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
}
ALTERNATIVE_NAME = "wget"
ALTERNATIVE_LINK = "${bindir}/wget"
ALTERNATIVE_PATH = "${bindir}/wget.${PN}"
ALTERNATIVE_PRIORITY = "100"

View File

@ -1,9 +0,0 @@
PR = "${INC_PR}.1"
SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
file://fix_makefile.patch \
"
SRC_URI[md5sum] = "1df489976a118b9cbe1b03502adbfc27"
SRC_URI[sha256sum] = "24c7710bc9f220ce23d8a9e0f5673b0efc1cace62db6de0239b5863ecc934dcd"
require wget.inc

View File

@ -1,3 +0,0 @@
# PN/PV are wrong inside the .inc file with 1.19.1
SYSMOCOM_ORIG_PV := "${PV}"
require recipes-core/busybox/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/dropbear/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-bsp/netbase/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-apps/tasks/${PN}_sysmocom.inc

View File

@ -1,13 +0,0 @@
# There is no point in packing qemu...
PRINC = "1"
# qemu removed
RDEPENDS_${PN} = "\
pkgconfig-nativesdk \
pseudo-nativesdk \
unfs-server-nativesdk \
opkg-nativesdk \
libtool-nativesdk \
autoconf-nativesdk \
automake-nativesdk \
"

View File

@ -1 +0,0 @@
require recipes-sysmobts/uboot/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-bsp/watchdog/${PN}_sysmocom.inc