Drop multi OpenEmbedded version support and target pyro or later

Move the shared files into yocto-fixes/ and the files from master. The
next step is maybe to remove the indirection again. We will see about
it in the future.
This commit is contained in:
Holger Hans Peter Freyther 2017-08-03 18:36:54 +08:00
parent 87fd9e70db
commit 9b654e0a7d
52 changed files with 2 additions and 514 deletions

View File

@ -3,14 +3,10 @@ BBPATH := "${BBPATH}:${LAYERDIR}"
# We have a packages directory, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILES += "${LAYERDIR}/yocto-shared/*.bbappend"
# Now we will need to include the matching fixes for a yocto version
BBFILES += "${BBFILES_SYSMOCOM_BSP}"
# selects specific distro or master when DISTRO_VERSION contains snapshot
BBFILES_SYSMOCOM_BSP = "${LAYERDIR}/yocto-${@dict([('1.5', 'dora')]).get(d.getVar('DISTRO_VERSION', True)[0:3],'master')}/*.bbappend"
BBFILES_SYSMOCOM_BSP += "${LAYERDIR}/yocto-${@dict([('1.5', 'dora')]).get(d.getVar('DISTRO_VERSION', True)[0:3],'master')}/*/*.bb"
# Fixes for the yocto version targeted
BBFILES += "${LAYERDIR}/yocto-fixes/*.bbappend ${LAYERDIR}/yocto-fixes/*/*.bb"
BBFILE_COLLECTIONS += "sysmocom-bsp"
BBFILE_PATTERN_sysmocom-bsp := "^${LAYERDIR}/"

View File

@ -1,5 +0,0 @@
# PN/PV are wrong inside the .inc file with 1.19.1
SYSMOCOM_ORIG_PV := "${PV}"
require recipes-core/busybox/${PN}_sysmocom.inc
require recipes-core/busybox/${PN}_sysmocom_systemd.inc
require recipes-core/busybox/${PN}_sysmocom_1.21.1.inc

View File

@ -1 +0,0 @@
require recipes-fixes/cronie/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom_systemd.inc

View File

@ -1 +0,0 @@
require recipes-fixes/dropbear/${PN}_sysmocom.inc

View File

@ -1,31 +0,0 @@
commit 9b38d507ec37b3d7d4df6095fa7ed16b47d399f7
Author: Drew Moseley <drew_moseley@mentor.com>
Date: Sat Mar 29 21:10:43 2014 -0400
configure.ac: Do not use readlink when cross compiling.
Do not use readlink to set ABS_GLIB_RUNTIME_LIBDIR when cross
compiling. Doing so causes host paths to potentially pollute
the target.
Note that in this case the path is not converted to absolute if
it contains any ".." references so it's not completely correct.
Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=727575]
Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
diff -rub glib-2.38.2.orig/configure.ac glib-2.38.2/configure.ac
--- glib-2.38.2.orig/configure.ac 2014-04-03 20:17:13.035567143 -0400
+++ glib-2.38.2/configure.ac 2014-04-03 20:19:07.071566057 -0400
@@ -275,7 +275,11 @@
[],
[with_runtime_libdir=""])
GLIB_RUNTIME_LIBDIR="$with_runtime_libdir"
+AS_IF([ test $cross_compiling = yes ], [
+ABS_GLIB_RUNTIME_LIBDIR="$libdir/$with_runtime_libdir"
+], [
ABS_GLIB_RUNTIME_LIBDIR="`readlink -m $libdir/$with_runtime_libdir`"
+])
AC_SUBST(GLIB_RUNTIME_LIBDIR)
AC_SUBST(ABS_GLIB_RUNTIME_LIBDIR)
AM_CONDITIONAL(HAVE_GLIB_RUNTIME_LIBDIR, [test "x$with_runtime_libdir" != "x"])

View File

@ -1,39 +0,0 @@
From 55253b55b9c65f3e0efbbe03cbab2a4c4014a16b Mon Sep 17 00:00:00 2001
From: Song.Li <Song.Li@windriver.com>
Date: Thu, 5 Jul 2012 15:09:41 +0800
Subject: [PATCH] add -march=i486 into CFLAGS automatically
Upstream-Status: Inappropriate [configuration]
glib configure will check if current gcc need -march=i486,
when gcc need -march=i486 but CFLAGS don't have,
glib configure will abort and advise the user to add -march=i486 or later.
This will break the build process,it's not good for automatic build system.
so change this to adding -march=i485 automatically when it is needed.
---
configure.ac | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
Index: glib-2.36.0/configure.ac
===================================================================
--- glib-2.36.0.orig/configure.ac
+++ glib-2.36.0/configure.ac
@@ -2378,7 +2378,7 @@ dnl
dnl Note that the atomic ops are only available with GCC on x86 when
dnl using -march=i486 or higher. If we detect that the atomic ops are
dnl not available but would be available given the right flags, we want
-dnl to abort and advise the user to fix their CFLAGS. It's better to do
+dnl to add -march=i486 automatically to fix their CFLAGS. It's better to do
dnl that then to silently fall back on emulated atomic ops just because
dnl the user had the wrong build environment.
@@ -2401,7 +2401,8 @@ AC_CACHE_CHECK([for lock-free atomic int
AC_TRY_COMPILE([],
[volatile int atomic = 2;\
__sync_bool_compare_and_swap (&atomic, 2, 3);],
- [AC_MSG_ERROR([GLib must be build with -march=i486 or later.])],
+ [AC_MSG_WARN([GLib must be build with -march=i486 or later.])
+ SAVE_CFLAGS="${SAVE_CFLAGS} -march=i486"],
[])
CFLAGS="${SAVE_CFLAGS}"
fi

View File

@ -1,39 +0,0 @@
From c53e94a520b573aa0dcf12903e9563fe8badc34c Mon Sep 17 00:00:00 2001
From: Marius Avram <marius.avram@intel.com>
Date: Wed, 27 Aug 2014 12:10:41 +0300
Subject: [PATCH] Allow /run/media/sdX drive mount if username root
In case that the username logged in the system is root
the drives are directly mounted in /run/media/sdX and
not /run/media/<username>/sdX as the function
g_unix_mount_guess_should_display() expects.
Without this change USB stick mounts are not accesible from
graphical applications such as the File Manager (pcmanfm).
Upstream-Status: Inappropriate
Signed-off-by: Marius Avram <marius.avram@intel.com>
---
gio/gunixmounts.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/gio/gunixmounts.c b/gio/gunixmounts.c
index 4999354..f6c1472 100644
--- a/gio/gunixmounts.c
+++ b/gio/gunixmounts.c
@@ -2136,6 +2136,11 @@ g_unix_mount_guess_should_display (GUnixMountEntry *mount_entry)
mount_path[sizeof ("/run/media/") - 1 + user_name_len] == '/')
is_in_runtime_dir = TRUE;
+ /* Allow no username in path in /run/media if current user is root */
+ if (strcmp(user_name, "root") == 0 &&
+ strncmp (mount_path, "/run/media/", sizeof("run/media")) == 0)
+ is_in_runtime_dir = TRUE;
+
if (is_in_runtime_dir || g_str_has_prefix (mount_path, "/media/"))
{
char *path;
--
1.7.9.5

View File

@ -1,60 +0,0 @@
From 1c5718648d49e795efee91c220a2bf9386c184f2 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 28 Apr 2012 18:24:50 +0200
Subject: [PATCH] configure: use $host_alias-libtool instead of libtool
directly
Poky renames libtool to $host_alias-libtool.
./$host_alias-libtool isn't created until after configure runs with
libtool >= 2.2.2
so we can't call # it at this point. We can safely assume a version is
available
from PATH though
Rebased to glib-2.27.3 by Dongxiao Xu <dongxiao.xu@intel.com>
Rebased to glib-2.32.1 by Martin Jansa <Martin.Jansa@gmail.com>
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
configure.ac | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index a6478c6..9a93d60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1470,7 +1470,7 @@ if test x"$glib_native_win32" = xyes; then
G_MODULE_LDFLAGS=
else
export SED
- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ G_MODULE_LDFLAGS=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
fi
dnl G_MODULE_IMPL= don't reset, so cmd-line can override
G_MODULE_NEED_USCORE=0
@@ -1535,9 +1535,9 @@ if test "$G_MODULE_IMPL" = "G_MODULE_IMPL_DL"; then
LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
echo "void glib_plugin_test(void) { }" > plugin.c
- ${SHELL} ./libtool --mode=compile --tag=CC ${CC} ${CFLAGS} \
+ ${SHELL} ./$host_alias-libtool --mode=compile --tag=CC ${CC} ${CFLAGS} \
${CPPFLAGS} -c -o plugin.lo plugin.c >/dev/null 2>&1
- ${SHELL} ./libtool --mode=link --tag=CC ${CC} ${CFLAGS} \
+ ${SHELL} ./$host_alias-libtool --mode=link --tag=CC ${CC} ${CFLAGS} \
${LDFLAGS} -module -o plugin.la -export-dynamic \
-shrext ".o" -avoid-version plugin.lo \
-rpath /dont/care >/dev/null 2>&1
@@ -1614,7 +1614,7 @@ fi
AC_MSG_CHECKING(for the suffix of module shared libraries)
export SED
-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
+shrext_cmds=`./$host_alias-libtool --config | grep '^shrext_cmds='`
eval $shrext_cmds
module=yes eval std_shrext=$shrext_cmds
# chop the initial dot
--
1.7.8.6

View File

@ -1,35 +0,0 @@
Rename 'rand' variable to avoid conflict.
Upstream-Status: pending
Signed-off-by: Björn Stenberg <bjst@enea.com>
diff -u glib-2.34.3/tests/refcount/signals.c~ glib-2.34.3/tests/refcount/signals.c
--- glib-2.34.3/tests/refcount/signals.c 2012-11-26 17:52:48.000000000 +0100
+++ glib-2.34.3/tests/refcount/signals.c 2013-02-08 14:24:10.052477546 +0100
@@ -9,7 +9,7 @@
#define MY_IS_TEST_CLASS(tclass) (G_TYPE_CHECK_CLASS_TYPE ((tclass), G_TYPE_TEST))
#define MY_TEST_GET_CLASS(test) (G_TYPE_INSTANCE_GET_CLASS ((test), G_TYPE_TEST, GTestClass))
-static GRand *rand;
+static GRand *grand;
typedef struct _GTest GTest;
typedef struct _GTestClass GTestClass;
@@ -84,7 +84,7 @@
NULL
};
- rand = g_rand_new();
+ grand = g_rand_new();
test_type = g_type_register_static (G_TYPE_OBJECT, "GTest",
&test_info, 0);
@@ -218,7 +218,7 @@
static void
my_test_do_prop (GTest * test)
{
- test->value = g_rand_int (rand);
+ test->value = g_rand_int (grand);
g_object_notify (G_OBJECT (test), "test-prop");
}

View File

@ -1,29 +0,0 @@
configure.ac: change readlink -f to -m
Change "readlink -f" to "readlink -m" since $libdir/$with_runtime_libdir
may not exist.
This patch should go to the upstream, I will send it sooner.
Upstream-Status: Pending
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -271,7 +271,7 @@ AC_ARG_WITH(runtime-libdir,
[],
[with_runtime_libdir=""])
GLIB_RUNTIME_LIBDIR="$with_runtime_libdir"
-ABS_GLIB_RUNTIME_LIBDIR="`readlink -f $libdir/$with_runtime_libdir`"
+ABS_GLIB_RUNTIME_LIBDIR="`readlink -m $libdir/$with_runtime_libdir`"
AC_SUBST(GLIB_RUNTIME_LIBDIR)
AC_SUBST(ABS_GLIB_RUNTIME_LIBDIR)
AM_CONDITIONAL(HAVE_GLIB_RUNTIME_LIBDIR, [test "x$with_runtime_libdir" != "x"])
--
1.8.1.2

View File

@ -1,24 +0,0 @@
# an very old patch cherry-picked in every glib-2.0 patch directory. The earliest container
# for it is 2.6.5 in OE. The earliest commit for it is c8e5702127e507e82e6f68a4b8c546803accea9d
# in OE side which ports from previous bitkeeper SCM. In OE side it's only used til 2.12.4.
#
# keep it since it's always cleaner to not hardcode destination path. Use @datadir@ is more
# portable here. mark for upstream
#
# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
# Rebased by Dongxiao Xu <dongxiao.xu@intel.com>, 11/16/2010
Upstream-Status: Inappropriate [configuration]
diff -ruN glib-2.27.3-orig/glib-gettextize.in glib-2.27.3/glib-gettextize.in
--- glib-2.27.3-orig/glib-gettextize.in 2009-04-01 07:04:20.000000000 +0800
+++ glib-2.27.3/glib-gettextize.in 2010-11-16 12:55:06.874605916 +0800
@@ -52,7 +52,7 @@
datadir=@datadir@
datarootdir=@datarootdir@
-gettext_dir=$prefix/share/glib-2.0/gettext
+gettext_dir=@datadir@/glib-2.0/gettext
while test $# -gt 0; do
case "$1" in

View File

@ -1,30 +0,0 @@
Instead of writing the temporary mapping files in the mappedfile test to the
user runtime directory, write them to $TMP. The runtime directory may not
currently exist if the test is executed on a non-desktop system and the test
doesn't attempt to create the directory structure.
Upstream-Status: Pending
Signed-off-by: Ross Burton <ross.burton@intel.com>
diff --git a/glib/tests/mappedfile.c b/glib/tests/mappedfile.c
index 40e0e60..27a24be 100644
--- a/glib/tests/mappedfile.c
+++ b/glib/tests/mappedfile.c
@@ -81,7 +81,7 @@ test_writable (void)
const gchar *new = "abcdefghijklmnopqrstuvxyz";
gchar *tmp_copy_path;
- tmp_copy_path = g_build_filename (g_get_user_runtime_dir (), "glib-test-4096-random-bytes", NULL);
+ tmp_copy_path = g_build_filename (g_get_tmp_dir (), "glib-test-4096-random-bytes", NULL);
g_file_get_contents (g_test_get_filename (G_TEST_DIST, "4096-random-bytes", NULL), &contents, &len, &error);
g_assert_no_error (error);
@@ -125,7 +125,7 @@ test_writable_fd (void)
int fd;
gchar *tmp_copy_path;
- tmp_copy_path = g_build_filename (g_get_user_runtime_dir (), "glib-test-4096-random-bytes", NULL);
+ tmp_copy_path = g_build_filename (g_get_tmp_dir (), "glib-test-4096-random-bytes", NULL);
g_file_get_contents (g_test_get_filename (G_TEST_DIST, "4096-random-bytes", NULL), &contents, &len, &error);
g_assert_no_error (error);

View File

@ -1,20 +0,0 @@
Fix DATADIRNAME on uclibc/Linux
translation files are always installed under PREFIX/share/locale in uclibc
based systems therefore lets set DATADIRNAME to "share".
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Upstream-Status: Pending
Index: glib-2.38.2/m4macros/glib-gettext.m4
===================================================================
--- glib-2.38.2.orig/m4macros/glib-gettext.m4 2013-11-07 07:29:13.000000000 -0800
+++ glib-2.38.2/m4macros/glib-gettext.m4 2014-03-15 14:51:54.712135644 -0700
@@ -239,7 +239,7 @@
[CATOBJEXT=.mo
DATADIRNAME=lib])
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-linux-uclibc*)
CATOBJEXT=.mo
DATADIRNAME=share
;;

View File

@ -1,23 +0,0 @@
require glib.inc
PE = "1"
SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
file://configure-libtool.patch \
file://fix-conflicting-rand.patch \
file://add-march-i486-into-CFLAGS-automatically.patch \
file://glib-2.0-configure-readlink.patch \
file://ptest-paths.patch \
file://uclibc.patch \
file://0001-configure.ac-Do-not-use-readlink-when-cross-compilin.patch \
file://allow-run-media-sdX-drive-mount-if-username-root.patch \
"
SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
SRC_URI[md5sum] = "05fb7cb17eacbc718e90366a1eae60d9"
SRC_URI[sha256sum] = "0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5"
EXTRA_OECONF += " --enable-static "

View File

@ -1,73 +0,0 @@
SUMMARY = "A general-purpose utility library"
DESCRIPTION = "GLib is a general-purpose utility library, which provides many useful data types, macros, type conversions, string utilities, file utilities, a main loop abstraction, and so on."
# pcre is under BSD;
# docs/reference/COPYING is with a 'public domai'-like license!
LICENSE = "LGPLv2+ & BSD & PD"
LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
file://glib/glib.h;beginline=4;endline=17;md5=b4f0f4a399c19e5ebb20c31b79d6bc32 \
file://gmodule/COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
file://gmodule/gmodule.h;beginline=4;endline=17;md5=b4f0f4a399c19e5ebb20c31b79d6bc32 \
file://glib/pcre/COPYING;md5=266ebc3ff74ee9ce6fad65577667c0f4 \
file://glib/pcre/pcre.h;beginline=11;endline=35;md5=de27f2bf633d20a2b7af0b1983423283 \
file://docs/reference/COPYING;md5=f51a5100c17af6bae00735cd791e1fcc"
BUGTRACKER = "http://bugzilla.gnome.org"
SECTION = "libs"
BBCLASSEXTEND = "native nativesdk"
DEPENDS = "glib-2.0-native virtual/libiconv libffi zlib"
DEPENDS_class-native = "pkgconfig-native gettext-native libffi-native zlib-native"
DEPENDS_class-nativesdk = "nativesdk-libtool nativesdk-gettext nativesdk-libffi nativesdk-zlib ${BPN}-native"
PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"
LEAD_SONAME = "libglib-2.0.*"
FILES_${PN}-utils = "${bindir}/* ${datadir}/glib-2.0/gettext"
inherit autotools gettext gtk-doc pkgconfig
S = "${WORKDIR}/glib-${PV}"
CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap --disable-man"
PRINTF = "--enable-included-printf=no"
PRINTF_darwin = "--enable-included-printf=yes"
PRINTF_mingw32 = "--enable-included-printf=yes"
EXTRA_OECONF = "${PRINTF} ${CORECONF}"
EXTRA_OECONF_class-native = "${CORECONF} --disable-selinux"
EXTRA_OECONF_append_libc-uclibc = " --with-libiconv=gnu"
do_configure_prepend() {
sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
}
FILES_${PN} = "${libdir}/lib*${SOLIBS} ${libdir}/gio ${datadir}/glib-2.0/schemas \
${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
FILES_${PN}-dev += "${libdir}/glib-2.0/include \
${libdir}/gio/modules/lib*${SOLIBSDEV} \
${libdir}/gio/modules/*.la"
FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb \
${libdir}/gio/modules/.debug \
${libdir}/glib-2.0/installed-tests/glib/.debug"
FILES_${PN}-codegen = "${datadir}/glib-2.0/codegen/*.py"
FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d \
${datadir}/bash-completion"
ARM_INSTRUCTION_SET = "arm"
USE_NLS = "yes"
do_install_append () {
if [ -f ${D}${bindir}/gtester-report ]; then
sed ${D}${bindir}/gtester-report -i -e '1s|^#!.*|#!/usr/bin/env python|'
fi
# Remove some unpackaged files
rm -f ${D}${datadir}/glib-2.0/codegen/*.pyc
rm -f ${D}${datadir}/glib-2.0/codegen/*.pyo
# Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
if [ -f ${D}${bindir}/glib-mkenums ]; then
sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
fi
}

View File

@ -1,79 +0,0 @@
DESCRIPTION = "ubi with rescue slot"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PACKAGES = ""
PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS = "mtd-utils-native"
do_fetch[cleandirs] = "${S}"
do_unpack[noexec] = "1"
do_patch[noexec] = "1"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install[noexec] = "1"
do_populate_sysroot[noexec] = "1"
do_package[noexec] = "1"
do_packagedata[noexec] = "1"
do_package_write_ipk[noexec] = "1"
do_package_write_deb[noexec] = "1"
do_package_write_rpm[noexec] = "1"
do_fetch[depends] = "virtual/kernel:do_build image-rauc-rescue-initramfs:do_build mtd-utils-native:do_populate_sysroot"
S = "${WORKDIR}"
do_fetch() {
mkdir -p "${S}/fs"
cp "${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}.bin" "${S}/fs/kernel"
cp "${DEPLOY_DIR_IMAGE}/image-rauc-rescue-initramfs-${MACHINE}.cpio.xz" "${S}/fs/initramfs"
}
do_fetch_append_gsmk-owhw() {
cp "${DEPLOY_DIR_IMAGE}/uImage-am335x-gsmk-owhw.dtb" "${S}/fs/devicetree"
}
IMAGE_ROOTFS = "${S}/fs"
IMAGE_NAME = "${PN}-${MACHINE}-${DATETIME}"
# Don't include the DATETIME variable in the sstate package sigantures
IMAGE_NAME[vardepsexclude] = "DATETIME"
IMAGE_LINK_NAME = "${PN}-${MACHINE}"
do_deploy() {
echo \[rescue\] > ubinize.cfg
echo mode=ubi >> ubinize.cfg
echo image=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rescue.ubifs >> ubinize.cfg
echo vol_id=0 >> ubinize.cfg
echo vol_size=14MiB >> ubinize.cfg
echo vol_type=dynamic >> ubinize.cfg
echo vol_name=rescue >> ubinize.cfg
echo \[system0\] >> ubinize.cfg
echo mode=ubi >> ubinize.cfg
echo vol_id=1 >> ubinize.cfg
echo vol_size=35MiB >> ubinize.cfg
echo vol_type=dynamic >> ubinize.cfg
echo vol_name=system0 >> ubinize.cfg
echo \[system1\] >> ubinize.cfg
echo mode=ubi >> ubinize.cfg
echo vol_id=2 >> ubinize.cfg
echo vol_size=35MiB >> ubinize.cfg
echo vol_type=dynamic >> ubinize.cfg
echo vol_name=system1 >> ubinize.cfg
echo \[data\] >> ubinize.cfg
echo mode=ubi >> ubinize.cfg
echo vol_id=3 >> ubinize.cfg
echo vol_size=16MiB >> ubinize.cfg
echo vol_type=dynamic >> ubinize.cfg
echo vol_name=data >> ubinize.cfg
echo vol_flags=autoresize >> ubinize.cfg
mkfs.ubifs --squash-uids -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rescue.ubifs ${MKUBIFS_ARGS}
ubinize -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.ubi ${UBINIZE_ARGS} ubinize.cfg
ln -sf ${IMAGE_NAME}.ubi ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.ubi
}
addtask deploy after do_fetch before do_build

View File

@ -1 +0,0 @@
require recipes-bsp/init-ifupdown/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/initscripts/${PN}_dora.inc

View File

@ -1 +0,0 @@
require recipes-fixes/iproute2/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-bsp/netbase/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1,3 +0,0 @@
require recipes-fixes/systemd/${PN}_dora.inc
require recipes-fixes/systemd/${PN}_sysmocom.inc

View File

@ -1,2 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom-${PV}.inc
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-sysmobts/uboot/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-bsp/watchdog/${PN}_sysmocom.inc

View File

@ -1,2 +0,0 @@
# add e2fsprogs for resize2fs need for bts installation
IMAGE_INSTALL_append = " e2fsprogs "

View File

@ -1 +0,0 @@
require recipes-core/initrdscripts/${PN}_sysmocom.inc

View File

@ -1 +0,0 @@
require recipes-fixes/${PN}/${PN}_angstrom.inc