wget: Add wget from meta-oe

Having wget available will allow to use it for online updates with opkg.
This commit is contained in:
Holger Hans Peter Freyther 2012-05-03 04:21:07 +08:00
parent 73bcda3f97
commit b863e59aa6
3 changed files with 88 additions and 0 deletions

View File

@ -0,0 +1,59 @@
Upstream-Status: Pending
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Index: wget-1.12/po/Makefile.in.in
===================================================================
--- wget-1.12.orig/po/Makefile.in.in 2009-09-04 09:31:54.000000000 -0700
+++ wget-1.12/po/Makefile.in.in 2011-10-19 20:32:53.714812160 -0700
@@ -8,8 +8,8 @@
# Please note that the actual code of GNU gettext is covered by the GNU
# General Public License and is *not* in the public domain.
#
-# Origin: gettext-0.17
-GETTEXT_MACRO_VERSION = 0.17
+# Origin: gettext-0.18
+GETTEXT_MACRO_VERSION = 0.18
PACKAGE = @PACKAGE@
VERSION = @VERSION@
Index: wget-1.12/configure.ac
===================================================================
--- wget-1.12.orig/configure.ac 2009-09-22 09:39:49.000000000 -0700
+++ wget-1.12/configure.ac 2011-10-19 20:32:53.714812160 -0700
@@ -110,7 +110,7 @@
dnl Gettext
dnl
AM_GNU_GETTEXT([external],[need-ngettext])
-AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT_VERSION([0.18])
AC_PROG_RANLIB
Index: wget-1.12/configure
===================================================================
--- wget-1.12.orig/configure 2009-09-22 09:40:13.000000000 -0700
+++ wget-1.12/configure 2011-10-19 20:33:46.578812174 -0700
@@ -5297,7 +5297,7 @@
- GETTEXT_MACRO_VERSION=0.17
+ GETTEXT_MACRO_VERSION=0.18
Index: wget-1.12/m4/po.m4
===================================================================
--- wget-1.12.orig/m4/po.m4 2009-09-04 09:31:54.000000000 -0700
+++ wget-1.12/m4/po.m4 2011-10-19 20:33:53.426812176 -0700
@@ -30,7 +30,7 @@
dnl Release version of the gettext macros. This is used to ensure that
dnl the gettext macros and po/Makefile.in.in are in sync.
- AC_SUBST([GETTEXT_MACRO_VERSION], [0.17])
+ AC_SUBST([GETTEXT_MACRO_VERSION], [0.18])
dnl Perform the following tests also if --disable-nls has been given,
dnl because they are needed for "make dist" to work.

View File

@ -0,0 +1,20 @@
DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
SECTION = "console/network"
LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "openssl"
INC_PR = "r13"
inherit autotools gettext update-alternatives
EXTRA_OECONF = "--with-libc --enable-ipv6 --with-libssl-prefix=${STAGING_DIR_HOST} --with-ssl=openssl"
do_install_append () {
mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
}
ALTERNATIVE_NAME = "wget"
ALTERNATIVE_LINK = "${bindir}/wget"
ALTERNATIVE_PATH = "${bindir}/wget.${PN}"
ALTERNATIVE_PRIORITY = "100"

View File

@ -0,0 +1,9 @@
PR = "${INC_PR}.1"
SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
file://fix_makefile.patch \
"
SRC_URI[md5sum] = "1df489976a118b9cbe1b03502adbfc27"
SRC_URI[sha256sum] = "24c7710bc9f220ce23d8a9e0f5673b0efc1cace62db6de0239b5863ecc934dcd"
require wget.inc