You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
31 lines
673 B
31 lines
673 B
SUMMARY = "small utility to configure MAC-addresses on ALIX/APU boards"
|
|
HOMEPAGE = ""
|
|
LICENSE = "GPLv2+"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
|
|
DEPENDS = "pciutils"
|
|
|
|
SRCREV = "2052514dc99575140af40b25e41c438c98eb9b48"
|
|
SRC_URI = "git://gitea.sysmocom.de/sysmocom/rtl8168-eeprom.git;protocol=https;branch=master"
|
|
PV = "v0.0.1+git${SRCPV}"
|
|
PR = "r0"
|
|
|
|
S = "${WORKDIR}/git"
|
|
|
|
inherit autotools pkgconfig
|
|
B = "${S}"
|
|
|
|
CFLAGS += ""
|
|
LDFLAGS += ""
|
|
|
|
CFLAGS += "`pkg-config --cflags libpci`"
|
|
LDFLAGS += "`pkg-config --libs libpci`"
|
|
|
|
do_configure() {
|
|
}
|
|
|
|
do_install() {
|
|
install -d ${D}${sbindir}/
|
|
install -m 0755 ${S}/rtl8168-eeprom ${D}${sbindir}/
|
|
}
|
|
|