cyassl: update to version 3.2.0

This fixes a security problem:
Security fix for RSA Padding check vulnerability

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

Backport of r42526

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42614 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2014-09-18 15:24:45 +00:00
parent f3c7b78225
commit 533282da86
2 changed files with 3 additions and 3 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
PKG_VERSION:=3.1.0
PKG_VERSION:=3.2.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
PKG_MD5SUM:=72477eb50697e759d309c49cb1aef18a
PKG_MD5SUM:=a80493c224ff86e45dc333c06d5edb88
PKG_FIXUP:=libtool
PKG_INSTALL:=1

View File

@ -1,6 +1,6 @@
--- a/src/internal.c
+++ b/src/internal.c
@@ -5600,6 +5600,10 @@ int ProcessReply(CYASSL* ssl)
@@ -6037,6 +6037,10 @@ int ProcessReply(CYASSL* ssl)
b1 =
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
ssl->curSize = (word16)(((b0 & 0x7f) << 8) | b1);