openssl: bump to 1.0.2c

fixes CVE-2015-4000 CVE-2015-1788 CVE-2015-1789 CVE-2015-1790 CVE-2015-1792 CVE-2015-1791

Signed-off-by: Steven Barth <steven@midlink.org>

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@45951 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2015-06-12 20:59:57 +00:00
parent 179bab8b17
commit d70e69464e
7 changed files with 18 additions and 32 deletions

View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.2a
PKG_VERSION:=1.0.2c
PKG_RELEASE:=0
PKG_USE_MIPS16:=0
@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
PKG_MD5SUM:=a06c547dac9044161a477211049f60ef
PKG_MD5SUM:=8c8d81a9ae7005276e486702edbcd4b6
PKG_LICENSE:=SSLEAY OPENSSL
PKG_LICENSE_FILES:=LICENSE

View File

@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
@@ -443,6 +443,12 @@ my %table=(
@@ -460,6 +460,12 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",

View File

@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
@@ -2076,6 +2076,11 @@ EOF
@@ -2103,6 +2103,11 @@ EOF
close(OUT);
}

View File

@ -34,9 +34,9 @@
-build_all: build_libs build_apps build_tests build_tools
+build_all: build_libs build_apps build_tools
build_libs: build_crypto build_ssl build_engines
build_libs: build_libcrypto build_libssl openssl.pc
@@ -538,7 +538,7 @@ dist:
@@ -528,7 +528,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@ -47,7 +47,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
--- a/Makefile.org
+++ b/Makefile.org
@@ -536,7 +536,7 @@ dist:
@@ -526,7 +526,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)

View File

@ -4,12 +4,12 @@
EXHEADER= e_os2.h
HEADER= e_os.h
-all: Makefile build_all openssl.pc libssl.pc libcrypto.pc
+all: build_all openssl.pc libssl.pc libcrypto.pc
-all: Makefile build_all
+all: build_all
# as we stick to -e, CLEARENV ensures that local variables in lower
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
@@ -395,11 +395,6 @@ openssl.pc: Makefile
@@ -398,11 +398,6 @@ openssl.pc: Makefile
echo 'Version: '$(VERSION); \
echo 'Requires: libssl libcrypto' ) > openssl.pc

View File

@ -1,7 +1,7 @@
--- a/Makefile.org
+++ b/Makefile.org
@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_t
build_libs: build_crypto build_ssl build_engines
@@ -277,17 +277,17 @@ build_libcrypto: build_crypto build_engi
build_libssl: build_ssl libssl.pc
build_crypto:
- @dir=crypto; target=all; $(BUILD_ONE_CMD)
@ -29,8 +29,8 @@
all_testapps: build_libs build_testapps
build_testapps:
@@ -453,7 +453,7 @@ report:
@$(PERL) util/selftest.pl
@@ -459,7 +459,7 @@ update: errors stacks util/libeay.num ut
@set -e; target=update; $(RECURSIVE_BUILD_CMD)
depend:
- @set -e; target=depend; $(RECURSIVE_BUILD_CMD)
@ -38,7 +38,7 @@
lint:
@set -e; target=lint; $(RECURSIVE_BUILD_CMD)
@@ -531,9 +531,9 @@ dist:
@@ -521,9 +521,9 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@ -50,7 +50,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
@@ -542,12 +542,19 @@ install_sw:
@@ -532,12 +532,19 @@ install_sw:
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
@ -71,7 +71,7 @@
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
@@ -631,12 +638,7 @@ install_html_docs:
@@ -621,12 +628,7 @@ install_html_docs:
done; \
done
@ -178,7 +178,7 @@
apps:
@(cd ..; $(MAKE) DIRS=apps all)
@@ -529,7 +529,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
@@ -530,7 +530,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)

View File

@ -1,14 +0,0 @@
--- a/ssl/t1_lib.c
+++ b/ssl/t1_lib.c
@@ -113,9 +113,11 @@
#include <openssl/objects.h>
#include <openssl/evp.h>
#include <openssl/hmac.h>
+#ifndef OPENSSL_NO_EC
#ifdef OPENSSL_NO_EC2M
# include <openssl/ec.h>
#endif
+#endif
#include <openssl/ocsp.h>
#include <openssl/rand.h>
#include "ssl_locl.h"