openwrt/target/linux/at91/patches/700-tqma9263-support.patch

26 lines
878 B
Diff

--- a/arch/arm/mach-at91/Kconfig.non_dt
+++ b/arch/arm/mach-at91/Kconfig.non_dt
@@ -258,6 +258,12 @@ config MACH_USB_A9263
Select this if you are using a Calao Systems USB-A9263.
<http://www.calao-systems.com>
+config MACH_TQMA9263
+ bool "TQ Components TQMa9263 board"
+ help
+ Select this if you are using the an TQ Components TQMa9263 board.
+ <http://www.tq-components.com/>
+
endif
# ----------------------------------------------------------
--- a/arch/arm/mach-at91/Makefile
+++ b/arch/arm/mach-at91/Makefile
@@ -68,6 +68,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
# AT91SAM9263 board-specific support
obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
obj-$(CONFIG_MACH_USB_A9263) += board-usb-a926x.o
+obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
# AT91SAM9RL board-specific support
obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o