r8169 upstream fix

svn path=/dists/trunk/linux-2.6/; revision=7646
This commit is contained in:
maximilian attems 2006-10-24 15:16:36 +00:00
parent 48e94efbd1
commit 7d1173290d
3 changed files with 26 additions and 1 deletions

3
debian/changelog vendored
View File

@ -21,8 +21,9 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
* Add sky2 lookup patch for the Marvell 88E803X Yukon-FE chip.
* Add upstream forcedeth swsusp support.
* r8169: PCI ID for Corega Gigabit network card.
* r8169: the MMIO region of the 8167 stands behin BAR#1.
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 17:02:56 +0200
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 17:15:59 +0200
linux-2.6 (2.6.18-3) unstable; urgency=low

View File

@ -0,0 +1,23 @@
From netdev-owner@vger.kernel.org Fri Sep 22 15:58:36 2006
From: Francois Romieu <romieu@fr.zoreil.com>
r8169: the MMIO region of the 8167 stands behin BAR#1
diff --git a/drivers/net/r8169.c b/drivers/net/r8169.c
index 805562b..93cd1f4 100644
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -210,7 +210,7 @@ static const struct {
static struct pci_device_id rtl8169_pci_tbl[] = {
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8129), 0, 0, RTL_CFG_0 },
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8136), 0, 0, RTL_CFG_2 },
- { PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8167), 0, 0, RTL_CFG_1 },
+ { PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8167), 0, 0, RTL_CFG_0 },
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8168), 0, 0, RTL_CFG_2 },
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8169), 0, 0, RTL_CFG_0 },
{ PCI_DEVICE(PCI_VENDOR_ID_DLINK, 0x4300), 0, 0, RTL_CFG_0 },
--
Ueimor

View File

@ -4,4 +4,5 @@
+ bugfix/net-netpoll.patch
+ bugfix/net-sky2-lockup.patch
+ features/net-forcedeth-swsusp.patch
+ bugfix/net-r8169-mmio8167.patch
+ features/net-r8169-pci_id-corega.patch